avetisov-84850
?>

ПИТОН! На дискотеке в ряд стоят три прожектора, которые поочерёдно светят в следующем порядке: левый, средний, правый, средний, левый, средний, правый, средний и т.д. (слева направо, затем налево, опять направо, ... Каждый прожектор горит в течение одной секунды. Известно, что лампа левого прожектора имеет ресурс A секунд горения, среднего – B секунд, правого – С секунд. Определите, сколько времени сможет продолжаться этот процесс горения прожекторов. Входные данные Программа получает на вход три целых неотрицательных числа A, B, C – время горения левого, среднего, правого прожектора. Выходные данные Программа должна вывести одно целое число. Система оценивания Решение, правильно работающее только для случаев, когда все входные числа не превосходят 10, будет оцениваться в Решение, правильно работающее только для случаев, когда все входные числа не превосходят 104, будет оцениваться в В будет оцениваться решение, правильно работающее, когда сумма всех входных чисел по модулю не превосходит 2×10^9 Пример: Ввод: 3 3 3 Вывод: 7 Пояснение: прожектора горят в следующем порядке: левый, средний, правый, средний, левый, средний, правый. После этого должен загореться средний прожектор, но он уже выработал ресурс и загореться не сможет. Поэтому процесс обрывается после 7 с.

Информатика

Ответы

contact
Корпоративные требования к почтовой перепискеписьмо состоит из трех частей1. Обращение2. текст письма3. Подпись4. исполнитель или сотрудник для связи с полными координатами(адреса: почтовый,E-mail, IСQ,телефон)
Сетевой этикет
Сетево́й этике́т (сетикет, нетикет — неологизм, является слиянием слов «сеть» (англ. net) и «этикет») — правила поведения, общения в Сети, традиции и культура интернет-сообщества, которых придерживается большинство. Это понятие появилось в середине 80-х годов XX века в эхоконференциях сети FIDO. Некоторые из правил сетевого этикета присутствуют в RFC 1855 (английский вариант).
Правила этикета не являются всеобщими и жестко установленными — в разных сообществах они могут значительно различаться. Так как основная цель этикета состоит в том, чтобы не затруднять общение в сообществе, правила могут устанавливаться исходя из целей сообщества, принятого стиля общения, технических ограничений, и т. д. Некоторые правила записаны, и даже оформляются в виде формального устава, а иногда и просто в виде списка, другие правила нигде не записаны, но известны большинству членов сообщества и строго соблюдаются.
martinzdraste
1)
#include<iostream>
#include<cmath>  
void main() {    
char ch1, ch2;    
int vol1, vol2;          
std::cin >> ch1 >> vol1;        
std::cin >> ch2 >> vol2;                            
if abs(ch1 - ch2) <= 2) && (abs(vol1 - vol2) <= 2)) && ((ch1 != ch2) && (vol1 != vol2))) && !((abs(ch1 - ch2)==1) && (abs(vol1-vol2))==1))             std::cout << "Possible";                    
else            
std::cout << "Impossible";        
}
3)
#include<iostream> 
using namespace std; 
void main() {    
int n,m;
cin >> n,m;
cout<<n;
for(int i=n;i<=m;i++)
cout<<i+2;
}
4)

#include <iostream>
using namespace std; void main(){
int mass[2][4]   //размерность своего массива вписывай.
{
{ 1, 2, 3, 4 },  //вписывай свои числа.
{ 1, 2, 3, 4 }  
};

for (int i=0 ; i<2;++i)
{
for (int j=0 ; j<4;++j)
{
if(mass[i][j]<0)
 cout<<mass[i][j];
}
}
system("pause");
}

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПИТОН! На дискотеке в ряд стоят три прожектора, которые поочерёдно светят в следующем порядке: левый, средний, правый, средний, левый, средний, правый, средний и т.д. (слева направо, затем налево, опять направо, ... Каждый прожектор горит в течение одной секунды. Известно, что лампа левого прожектора имеет ресурс A секунд горения, среднего – B секунд, правого – С секунд. Определите, сколько времени сможет продолжаться этот процесс горения прожекторов. Входные данные Программа получает на вход три целых неотрицательных числа A, B, C – время горения левого, среднего, правого прожектора. Выходные данные Программа должна вывести одно целое число. Система оценивания Решение, правильно работающее только для случаев, когда все входные числа не превосходят 10, будет оцениваться в Решение, правильно работающее только для случаев, когда все входные числа не превосходят 104, будет оцениваться в В будет оцениваться решение, правильно работающее, когда сумма всех входных чисел по модулю не превосходит 2×10^9 Пример: Ввод: 3 3 3 Вывод: 7 Пояснение: прожектора горят в следующем порядке: левый, средний, правый, средний, левый, средний, правый. После этого должен загореться средний прожектор, но он уже выработал ресурс и загореться не сможет. Поэтому процесс обрывается после 7 с.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Pgr100
ldstroy
e-liza-k
kate281078
Shcherbinin KOLIChEVA
tretyakovamarina201155
Ильдар-Кугай
Александра Викторович531
100 нарисовать замок в паскаль абс ​
Svetlana1335
barg562
yurkovam-037
nataliaprintroll
Shurshilina850
AkimovaI1608
Mariya Filippov