kovalenko262
?>

Заполните одномерный массив из 20 элементов случайными четными числами. Найдите максимальный элемент в первой половине массива, минимальный элемент во второй половине массива и замените элементы массива, находящиеся в массиве между ними, на 0. Выведите на экран исходный и полученный массивы, а также ответ на заданный во Решение хотя бы одной из подзадач оформите в виде пользовательской подпрограммы.

Информатика

Ответы

Павловна1750
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
EVLAMPIN56
Const n=20;
var a:array[1..n]of integer;
i,b,k,c,f,g,h:integer;
begin
for i:=1 to n do a[i]:=Random(70)-20;
for i:=1 to n do
write(a[i],' ');
writeln;
for i:=1 to n do begin
if (a[i] mod 5 = 0) and (a[i] mod 10<>0) or (a[i]=50) then begin
b:=i;
for b:=i to (n-1) do
a[i]:=a[i+1];
end; end;
for i:=1 to n do
write(a[i],' ');
write('введите к ');
read(k);
for i:=1 to n do begin
if a[i] mod i = 0 then begin
c:=i;
for i:=n downto c+1 do begin
a[i]:=a[i-1];
a[c+1]:=k;
end;end;end;
for i:=1 to n do
write(a[i],' ');
writeln;
f:=0; g:=0;
for i:=n downto 1 do begin
if (a[i]>0) then f:=i;
end;
if a[f]=0 then write('нет положительных ');
for i:=n downto 1 do begin
if (a[i]<0) then g:=i;
end;
if (a[g]=0) then write('нет отрицательных ');
if (a[f]<>0) and (a[g]<>0) then begin
h:=a[f]; a[f]:=a[g]; a[g]:=h; end;
for i:=1 to n do
write(a[i],' ');
writeln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заполните одномерный массив из 20 элементов случайными четными числами. Найдите максимальный элемент в первой половине массива, минимальный элемент во второй половине массива и замените элементы массива, находящиеся в массиве между ними, на 0. Выведите на экран исходный и полученный массивы, а также ответ на заданный во Решение хотя бы одной из подзадач оформите в виде пользовательской подпрограммы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Дмитриевич Бирковская69
MISAKOVNA49
magazin-71
Bolshakova Shigorina
departed744
Caragyant
deputy810
luksorsps20096124
nestruev
ekaterinkat
evainvest1
khvorykhphoto
makashi28
sanseth5
gelena03
▲