dubaiexport
?>

ПАСКАЛЬ1. Даны два действительных числа. Найти их сумму, разность, произведение и частное.2. Даны действительные положительные числа a, b, c. Выяснить, существует ли треугольник с длинами сторон a, b, c.3. Написать программу печатающую на экране значения х, х2, х3, если х меняется от 1 до 15.4. Написать программу вычисления среднего арифметического целых чисел на отрезке от 1 до N (N вводится с клавиатуры5. Допустим, вы получили наследство $ 1 000 000 и хотите красиво пожить. После долгих раздумий вы решаете, что будете жить на $ 800 в месяц. На сколько лет вам хватит наследства ПАСКАЛЬ1. Даны два действительных числа. Найти их сумму, разность, произведение">

Информатика

Ответы

vasinam

1)

var

a, b: integer;

begin

Readln(a, b) ;

Writeln('Сумма ', a + b, '; ', 'Разность ', a - b, '; ', 'Произведение ', a * b, '; ', 'Частное ', a / b);

end.

samuilik-v

1) Задаешь проверку: введеные числа меньше 7?

Если да - сохраняешь это число в переменную.

В конце все переменные, которые записывались - умножаешь. Все пустые переменные были равны 1, т.е. если ты их умножишь - все останется ок.

2) Задаешь проверку: введеные числа при делении на 100 > 0?

Если да - счетчик + 1.

3) Задаешь проверку: введеные числа > 10?

Если да - 1счетчик + 1

Если нет - 2счетчик + 1

Сравниваешь счетсчики.

4) Задаешь проверку: введеные числа > 12 и < 40?

Если да: проверяешь, кратно ли число 7 (число % 7 == 0)

Делаешь выводы. Выводишь результат

Не за что. Удачи!

Suralevartem

189 и 475 взаимно простые числа

Числа 189 и 475 имеют только один общий делитель — число 1. Такие числа называют взаимно простыми числами.

Как найти наибольший общий делитель для 189 и 475

Разложим на простые множители 189

189 = 3 • 3 • 3 • 7

Разложим на простые множители 475

475 = 5 • 5 • 19

Выберем одинаковые простые множители в обоих числах.

Одинаковые простые множители отсутствуют

Находим произведение одинаковых простых множителей и записываем ответ

НОД (189; 475) = 1

НОК (Наименьшее общее кратное) 189 и 475

Наименьшим общим кратным (НОК) 189 и 475 называется наименьшее натуральное число, которое само делится нацело на каждое из этих чисел (189 и 475).

НОК (189, 475) = 89775

ЧАСТНЫЙ СЛУЧАЙ!

189 и 475 взаимно простые числа

Так как взаимно простые числа не имеют общих простых делителей, то их наименьшее общее кратное равно произведению этих чисел.

НОК (189, 475) = 189 • 475 = 89775

Как найти наименьшее общее кратное для 189 и 475

Разложим на простые множители 189

189 = 3 • 3 • 3 • 7

Разложим на простые множители 475

475 = 5 • 5 • 19

Выберем в разложении меньшего числа (189) множители, которые не вошли в разложение

3 , 3 , 3 , 7

Добавим эти множители в разложение бóльшего числа

5 , 5 , 19 , 3 , 3 , 3 , 7

Полученное произведение запишем в ответ.

НОК (189, 475) = 5 • 5 • 19 • 3 • 3 • 3 • 7 = 89775

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПАСКАЛЬ1. Даны два действительных числа. Найти их сумму, разность, произведение и частное.2. Даны действительные положительные числа a, b, c. Выяснить, существует ли треугольник с длинами сторон a, b, c.3. Написать программу печатающую на экране значения х, х2, х3, если х меняется от 1 до 15.4. Написать программу вычисления среднего арифметического целых чисел на отрезке от 1 до N (N вводится с клавиатуры5. Допустим, вы получили наследство $ 1 000 000 и хотите красиво пожить. После долгих раздумий вы решаете, что будете жить на $ 800 в месяц. На сколько лет вам хватит наследства ПАСКАЛЬ1. Даны два действительных числа. Найти их сумму, разность, произведение">
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Sadovskaya425
vladai2
voropayelena26
mrubleva42
mukbidc
irinatikhonov
dobrovolsky-tmz1
anton-www1
Яна_Софья
v-shevlyakov7992
Yurevna419
vkorz594
Shikhova-Vitalii1290
melnik-738
Хабарьева Андрей1056