bolosolo77
?>

1)Написать программу для поиска решения задачи. Плата за одного быка составляет 20 гривен, за корову - 10 гривен, за теленка - 1 гривна. Сколько можно купить быков, коров и телят, если на 200 гривен надо купить 100 голов скота?2)Написать программу для поиска решения задачи. Сколько в зоопарке страусов и верблюдов, если вместе у них 40 ног?3)написать программу для поиска решения задачи. Найдите все двузначные числа, которые делятся на произведение их цифр.Язык программирования Python

Информатика

Ответы

bolosolo77

1)      видим, что в последней строке выводятся на экран переменные a и b, поэтому сначала нужно определить, что они обозначают в программе

2)      перед началом цикла переменные a и  b обнуляются

3)      на каждом шаге цикла при выполнении некоторого условия переменная a увеличивается на 1, а b увеличивается на x mod 10, то есть, на остаток от деления x на 10 – это последняя цифра десятичной записи числа x  

4)      в конце каждого шага цикла операция x:=x div 10 отсекает последнюю цифру в десятичной записи числа

5)      цикл заканчивается, когда перестаёт выполняться условие x > 0, то есть, когда все цифры исходного числа отброшены

6)      таким образом, делаем вывод: после завершения цикла в переменной a находится количество цифр в десятичной записи числа, а в переменной b – их сумма

7)      если было выведено 2 и 12, то в числе 2 цифры, и их сумма равна 12; таким образом, нам нужно найти все двузначные числа, в котором сумма значений цифр равна 12

8)      число 12 может быть разложено на два слагаемых, меньших 10, как

12 = 3 + 9 = 4 + 8 = 5 + 7 = 6 + 6 = 7 + 5 = 8 + 4 = 9 + 3,

нам подходят числа 39, 48, 57, 66, 75, 84 и 93

arturusinsk5
program task31153145; const  N = 10; var  arr: array[1..N] of integer;  S, indexOfFifty: integer;  haveFifty: boolean; begin  haveFifty := false;  for var i := 1 to N do    begin      arr[i] := Random(100);      if (arr[i] > 10) and (arr[i] < 30) then        S := S + arr[i];          if arr[i] = 50 then            begin              indexOfFifty := i;              haveFifty := true;            end;    end;  if haveFifty = true then    Writeln('В МАССИВЕ ЕСТЬ ЧИСЛО 50, ЕГО ИНДЕКС = ', indexOfFifty)  else    Writeln('В МАССИВЕ НЕТ ЧИСЛА 50');  Writeln('S = ', S); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)Написать программу для поиска решения задачи. Плата за одного быка составляет 20 гривен, за корову - 10 гривен, за теленка - 1 гривна. Сколько можно купить быков, коров и телят, если на 200 гривен надо купить 100 голов скота?2)Написать программу для поиска решения задачи. Сколько в зоопарке страусов и верблюдов, если вместе у них 40 ног?3)написать программу для поиска решения задачи. Найдите все двузначные числа, которые делятся на произведение их цифр.Язык программирования Python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

konstantin0112
K=x3 – 4xy(x+y2) Это сор!! ​
orantus3
mbudilina
родичева1812
Galkin683
egcuzn86
bellaalya13862
ver2bit29
aksmobile
buhh20104519
knyazevskayad
Blekjek730
mvolkov8
elbabitch2014
pri02