vis-lyubov8832
?>

Написать программу, которая считывает текст из файла и выводит на экран предложения, содержащие цифры.​

Информатика

Ответы

diana-kampoteks

Программа:

program files;

var f: text;

   c: string;

begin

 

 assign(f, 'path/to/file.txt');

 reset(f);

 

 while not eof(f)

 do begin

      readln(f,c);

      if(c.Contains('1') or c.Contains('2')

           or c.Contains('3') or c.Contains('4')

             or c.Contains('5') or c.Contains('6')

               or c.Contains('7') or c.Contains('8')

                 or c.Contains('9'))

      then writeln(c);

 end;

 

 close(f);

 

end.

abroskin2002
1) 1000000
ответ:1
2)44100*60*2*24=127008000 бит = 15876000 байт = 15503 Кб
3) пусть время х. тогда:
1/3*х * 60 + 2/3*х * 90 = 27000
20х + 60х = 27000
8х=2700
х=337 секунд
4)102 + 108 +1016 = 1226 = 10011001010(2)
5)???
6)128*16=2048 пикселей
512/2048 = 1/4 байта/пиксель = 2 бита/пиксель
2^2 = 4
ответ: 4 цвета
7)256 = 2^8 -> 8 бит/пиксель = 1 байт/пиксель
256*512*1=131072 байт = 128 Кб
8)128 Тбайт = 128 * 1024 * 1024 * 1024 * 1024 * 8 бит = 1125899906842624 бит
9)???
10) 1024 = 2^10
10*60*48000*10 = 288000000 бит = 35156 Кбайт
11)  16*32*64*16 = 524288 бит = 64 Кбайт
12) 44 символа * 1 байт/символ = 44 байта
13)??? (ничего не подходит под первый символ)
mdclcompany
1) 1000000
ответ:1
2)44100*60*2*24=127008000 бит = 15876000 байт = 15503 Кб
3) пусть время х. тогда:
1/3*х * 60 + 2/3*х * 90 = 27000
20х + 60х = 27000
8х=2700
х=337 секунд
4)102 + 108 +1016 = 1226 = 10011001010(2)
5)???
6)128*16=2048 пикселей
512/2048 = 1/4 байта/пиксель = 2 бита/пиксель
2^2 = 4
ответ: 4 цвета
7)256 = 2^8 -> 8 бит/пиксель = 1 байт/пиксель
256*512*1=131072 байт = 128 Кб
8)128 Тбайт = 128 * 1024 * 1024 * 1024 * 1024 * 8 бит = 1125899906842624 бит
9)???
10) 1024 = 2^10
10*60*48000*10 = 288000000 бит = 35156 Кбайт
11)  16*32*64*16 = 524288 бит = 64 Кбайт
12) 44 символа * 1 байт/символ = 44 байта
13)??? (ничего не подходит под первый символ)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая считывает текст из файла и выводит на экран предложения, содержащие цифры.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Рогова Ольга1156
Kateshaeva
Pochkun-Oleg
сузанна_Людмила
Stenenko
Batrakova-Anna
avguchenkov
mvolkov8
Shevtsov1818
Leon-12
olechka197835
Ахмедшина Трубников1249
blizzardtap641
volodin-alexander
Belov Yekaterina639