sveta300856729
?>

Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P > 4

Информатика

Ответы

Irina_Nikolai
var K, P, i: integer;beginread(K);i := 1;while i < K dobegini := i + 3;P := P + i;end;Print(P);end.

или:

beginvar K := ReadInteger('K:');Print((4+K)/2*((K-4)/3+1));end.

Примеры работ:


Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P >
Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P >
dkvsadovoe
"Типовой школьный" Паскаль:

// PascalABC.Net 3.0, сборка 1064
const
  k = 100;

var
  s, wd: string;
  i, j, m, n, pt, step: integer;
  Words, WordsSort: array[1..k] of string;
  InOrder: boolean;

begin
  Write('Введите строку: '); Readln(s);
  n := Length(s); pt := 1; m := 0;
  repeat
    // Пропускаем все символы до первого непробельного
    while pt <= n do
      if Ord(s[pt]) <= 32 then Inc(pt) else break;
    if pt <= n then begin
      // Выделяем очередное слово
      wd := '';
      while pt <= n do
        if Ord(s[pt]) > 32 then begin wd := wd + s[pt];Inc(pt) end
        else break;
      if wd <> '' then begin Inc(m);Words[m] := wd end
    end
  until pt > n;
  // Теперь Words содержит все m слов.
  // Отсортируем их в массиве WordsSort методом Шелла
  for i := 1 to m do WordsSort[i] := Words[i];
  step := m div 2;
  while step > 0 do begin
    for j := m - step downto 1 do begin
      i := j;
      while i <= m - step do begin
        if WordsSort[i] > WordsSort[i + step] then begin
          wd := WordsSort[i];
          WordsSort[i] := WordsSort[i + 1];
          WordsSort[i + 1] := wd
        end;
        i := i + step
      end
    end;
    step := step div 2
  end;
  // Осталось поэлементно сравнить оба массива
  InOrder := true; i := 1;
  while InOrder and (i <= m) do
  begin InOrder := (Words[i] = WordsSort[i]); Inc(i) end;
  if m = 0 then Writeln('Строка не содержит слов')
  else
    if InOrder then Writeln('Cлова упорядочены')
    else Writeln('Cлова не упорядочены')
end.

Тестовое решение:
Введите строку: слово1    слово2    слово3    слово4 слово5
Cлова упорядочены

Введите строку: слово1    слово2    слово4    слово3 слово5
Cлова не упорядочены

"Современный" вариант решения на Паскале:

// PascalABC.Net 3.0, сборка 1064
var
  s:string;
begin
  Write('Введите строку: '); Readln(s);
  var Delim:=Range(0,32).Select(x->Chr(x)).ToArray;
  var Words:=s.Split(Delim).Where(x->x<>'');
  var WordsSort:=Words.Sorted;
  if Words.SequenceEqual(WordsSort) then Writeln('Cлова упорядочены')
  else Writeln('Cлова не упорядочены')
end.

Тестовое решение совпадает с вышеприведенным.
Artyom
972₁₀ = 1111001100₂
1. Число будет иметь минимальное значение, если в нем будет минимально возможное количество значащих разрядов. Таких циклическх сдвигов в данном случае возможно 2 (запишем их друг под другом):
0011001111 - циклический сдвиг на 4 разряда влево;
0011110011 - циклический сдвиг на 8 разрядов влево;
2. При равном количестве разрядов меньшим будет то число, у которого при просмотре разрядов слева направо встретится ноль, в то время как у второго в этом же разряде будет единица (это место выделено):
11001111 - это число меньшее из двух.
11110011
ответ: 11001111₂ = 207₁₀

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке Паскаль для вычисления суммы: Р = 4 + 7 +10 + 13. . . + K , где P > 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

infooem
antonkovalev89
mpityk
Глазкова633
mikhail
ftyh6
ivstigres65
sav4ukoxana7149
Gstoremsk62
Mexx9050
samira57
ellyb106786
aleksey7800
adel25159
yok887062