avto3132
?>

2)Дан массив состоящий из 10 целых чисел. Ввод через клавиатуру напишите программу, которая подсчитает количество элементов массива меньших максимального элемента. 3)Дан массив аостоящий из целых чисел Заполните через генератор случайных чисел. Найти сумму тех элементов массивауоторые одновременно имеют нечетные положительные значения. 4)Дан массив состоящий из 10 цнелых чисел Заполнение через генератор случайных чисел. Напишите программу которая находит и выводит максимальное значение среди элементов, стоящих на четных позициях кто-нибудьь помагите на кону моя жизньь Люди дрбрые

Информатика

Ответы

sodrugestvo48
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]
Камочкин
Символ-это набор команд состоящих из единиц и нулей,любое слово вводимое тобой или выведонное тебе состоит из этих последовательностей. Например символ I (Я) зашифрован так 0100 1001 <-- 8 этих битов образуют 1 символ,называемым байтом,поэтому любой текст,изображение,видео(там немного другая схема действует),все это всего лишь грандиозный набор команд,разговоры по телефону тоже кодируются из вибрации в набор импульсов и на обратном выходе опять преобразуются в нам всем привычные слова.Любые механизмы,и даже мы с Вами можем передавать информацию,в том числе Азбукой Морзе,даже несколько последовательно сформулированных щелчков пальцев несут в себе информацию,главное ее понять,расшифровать и преобразовать,в видео,аудио,текст,фотографию.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

2)Дан массив состоящий из 10 целых чисел. Ввод через клавиатуру напишите программу, которая подсчитает количество элементов массива меньших максимального элемента. 3)Дан массив аостоящий из целых чисел Заполните через генератор случайных чисел. Найти сумму тех элементов массивауоторые одновременно имеют нечетные положительные значения. 4)Дан массив состоящий из 10 цнелых чисел Заполнение через генератор случайных чисел. Напишите программу которая находит и выводит максимальное значение среди элементов, стоящих на четных позициях кто-нибудьь помагите на кону моя жизньь Люди дрбрые
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

levsha-27509
Марина_Мария
Galinagol559
marusyamr
shoora
inj-anastasia8
Viktoriya
Сергеевич1907
Михаил736
nurtilekisakov
Shitikov-M.A.1307
tkmandarin8376
Anton-Yurevich222
Viktoriya
ilez03857