salahovta
?>

Написать программу, которая: заполняет квадратную матрицу из символов размером 3×2 элементов случайными целыми числами на промежутке [-100; 100), выводит заполненную матрицу на экран и находит количество положительных элементов.​

Информатика

Ответы

zoocenterivanoff51
N = 2^{i}
i - кол-во бит
N - мощность (кол-во всех возможных вариаций)
Корабль передаёт либо длинный, либо короткий значит может принимать всего 2 состояния. Он отправляет 6 сигналов (3 коротких 3 длинных) Значит код-во возможных вариаций расстановок этих сигналов будет равна 2^{6}
Подставим в формулу
2^{6} = 2^{i}
Следовательно i  = 6
Кол-во бит информации - 6
ответ: 6
///////////////////////////////////////////////////////
А вообще для таких задач я использую такую формулу
log_{2}K = i
K - сколько всего может быть исходов, i - кол-во бит

Корабль может передавать либо короткий, либо длинный сигнал. Значит кол-во состояний - 2
Он передаёт 3 коротких и 3 длинных, значит всего - 3+3 = 6
кол-во всех возможных исходов при 6 сигналах и кол-во состояний будет равно 2^{6}
Если ты понимаешь суть логарифма, то ответ уже думаю тебе ясен, если нет, то читай дальше :)
Подставляем в нашу формулу кол-во возможных событий
log_{2}( 2^{6}) = i
логарифм по основанию a, это значит надо найти такою степень числа a, при возведении в которую получится число, которое в выражении логарифма, а так как мы в логарифме по основанию 2 возводим число 2, то тут и вычислять нечего. Просто пишем степень двойки.
Это число 6.
Шарабанов

ответ: Считываем первое число(n), чтобы определить, до какого момента должен продолжаться цикл. Создаем переменную sum, чтобы хранить найденное количество чисел, удовлетворяющих условию. Запускаем цикл, считываем число, если последняя цифра - 4 (проверяем при получения остатка от деления на 10) и число делится на 6 (проверяем при получения остатка от деления на 6), то добавляем к в переменную sum 1.

n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

Объяснение: n = int(input())

sum = 0

for i in range(0, n):

  current = int(input())

  if current % 10 == 4 and current % 6 == 0:

      sum += 1

print(sum)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая: заполняет квадратную матрицу из символов размером 3×2 элементов случайными целыми числами на промежутке [-100; 100), выводит заполненную матрицу на экран и находит количество положительных элементов.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatgri
akakne86
appmicom
elivanova
Iiexota280274
buslavgroupe
heodbxbbshe
annaar497
Раисовна878
Андрееевич787
Светлана-Тигран
elena-ruzadom
Ruslan374
Feyruz90
twisty20075004