veniaminsem
?>

Нужно написать программу в паскале которая будет создавать окошко graphABC, далее запрашивать радиус окружности, после строить окружность по координатам x = 30, y = 30, и циклом for создать эффект движения окружности по краям окошка, окружность должна описать прямоугольник, после этого программа завершится. При каждом шаге старая окружность должна удаляться, шаг окружности - 10, задержка 250, цвет окружности красный.

Информатика

Ответы

IPMelnikovR146
Знаменитые тезки Алевтины: Алевтина Кесарийская (Палестинская), христианская мученица, пострадавшая в гонение императора Максимина (ум.308) Алевтина Степанова, главная героиня трилогии Юрия Германа («Дело, которому ты служишь», «Дорогой мой человек» и «Я отвечаю за все») Алевтина мученицаТак уж случилось, что истории известно совсем немного знаменитых Алевтин, что и неудивительно, если вспомнить о достаточной редкости этого красивого имени. Однако, наверное, вовсе не обязательно обладать какими-либо особыми талантами для того, чтобы оставить по себе добрую память потомкам. Так, в православных календарях день 16 июля (по старому стилю) посвящен светлой памяти мученицы Алевтины, не отличавшейся ни особыми чудесами, ни исцелениями страждущих, ни какими-то из ряда вон выходящими деяниями. Ничего сверхъестественного, вроде бы, не случилось, просто в этот день в 308 году в Палестинской Кесарии пострадала за веру Христову простая женщина Алевтина, изумившая своих палачей тем, что мужественно держалась и не отреклась от своей веры. Но разве этого мало?


Значение и происхождение имени Алевтина: Предположительно имя является народной формой латинского имени Валентина, "Сильная" Тайна имени и характер Алевтины: По своей энергетике это имя довольно мягкое и легкое, однако в нем все же чувствуется некоторая взрывоопасность. Кроме этого, мелодия имени пробудить в Алевтине мечтательность и чувство непохожести на других. Это еще более усиливается тем, что на сегодняшний день такое имя встречается довольно редко, что делает Алю заметной практически в любом коллективе. Причем очень вероятно, что именно эта заметность сыграет свою роль в развитии значительного самолюбия Алевтины, поскольку, с одной стороны имя довольно красиво, с другой же – в нем слышится нечто старомодное, а в юности это доставить массу неприятностей. Не исключено, что самолюбие Али будет весьма болезненным, и она будет чувствовать себя среди подружек несколько неуютно, хотя в душе у нее может зреть уверенность в своей неповторимости и даже в своем превосходстве. Быть может, будь имя потверже и понапряженнее, то это и не было бы так опасно, однако как раз твердости в имени и не хватает.Все это приводит к тому, что чаще всего Алевтина не спокойно перенести обычный в женском коллективе обмен колкостями, ее чувствительное самолюбие и отсутствие склонности к сдержанности нередко позволяют ей завестись, что называется, с полоборота и там, где могло бы быть легкое недовольство, возникает серьезный конфликт. Надо сказать, что в такой ситуации уже трудно разобраться, где причина, где следствие, поскольку здесь получается замкнутый круг – чем больше возникает конфликтов, тем легче Алевтина начинает срываться на язвительность, что, соответственно, рождает новые конфликты. Нередко Аля вообще перестает общаться с женской половиной коллектива, предпочитая общение с мужчинами, с которыми она чувствует себя значительно лучше и гораздо увереннее.Скорее всего, Алевтина будет долго выбирать себе мужа, причем постарается выбрать его из каких-либо высоких кругов, что связано как с ее мечтательностью и честолюбием, так и с поиском возможности самоутвердиться. Впрочем, и здесь, как и в общении с подружками, ей следует быть осторожней, ведь любая совместная жизнь, даже если муж стопроцентный ангел, таит в себе множество недоразумений и обид, так что если Алевтина не преодолеет свою взрывоопасность, частые семейные ссоры поставить семью на грань развода.Секреты общения с Алевтиной: Мужчина может не опасаться, когда случайно доверит Алевтине какую-либо тайну, связанную с женщинами, – если она и сплетничает с кем-то, то уж никак не в женском коллективе. Кроме того, в случае общения с Алевтиной нелишне будет подготовиться к ее язвительности и колкостям. Часто они достаточно болезненны.Астрологическое соответствие имени Алевтина Зодиакальное соответствие имени: Дева Планета-покровитель: Марс Черты характера: Мечтательность, эмоциональность, импульсивность Цвета имени: Красный, синий, салатовый Счастливые цвета: Зеленый Святые покровители имени: Алевтина Кесарийская (именины 29 июля) Камень-талисман: Изумруд, нефрит
fotomuha1
// PascalABC.NET 3.3, сборка 1633 от 10.02.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var x:=ReadReal('x=');
  var y:=Sqr((1-x*x+5*Sqr(x*x)));
  Writeln('y=',y)
end.

Пример
x= 4.12
y=2029704.2032886

2a.
 
begin
  var x:=ReadReal('x=');
  var t1:=x*x; // x^2
  var t2:=t1*t1; // x^4
  t2:=t2*t2; // x^8
  t1:=t2*t1; // x^10
  Writeln('x^10=',t1)
end.

2b.

begin
  var x:=ReadReal('x=');
  var t:=x*x; // x^2
  t:=t*t; // x^4
  t:=t*t; // x^8
  t:=t*t; // x^16
  t:=t/x; // x^15
  Writeln('x^15=',t)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу в паскале которая будет создавать окошко graphABC, далее запрашивать радиус окружности, после строить окружность по координатам x = 30, y = 30, и циклом for создать эффект движения окружности по краям окошка, окружность должна описать прямоугольник, после этого программа завершится. При каждом шаге старая окружность должна удаляться, шаг окружности - 10, задержка 250, цвет окружности красный.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilyagenius
starabanov
uvarovig
salesrawtogo
juliapierrat
Хабарьева Андрей1056
rubanvladimir374
Aleksei368
sveta1864
Курнев-Анастасия359
Ушакова1902
yastrik
alexderru
denis302007
aivia29