ВадимСмирнов116
?>

Информатика, 10 классрешите задачу стандартными методами Паскаля, без сложных функций. (без чар и орд)напишите программу которая выполняет шифрование строки с шифра цезаря​

Информатика

Ответы

Панков1101
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('Первое слово:');
  var s2:=ReadlnString('Второе слово:');
  // #1
  Writeln('Задание 1) ',s1.Length>s2.Length?s1:s2);
  // #2
  if s1[1]=s1[2] then Writeln('Задание 2) ',s1);
  if s2[1]=s2[2] then Writeln('Задание 2) ',s2);
  // #3
  Write('Задание 3) Более короткое слово ');
  // предполагаем, что s1 более короткое.
  // Если это не так, меняем их местами.
  if s1.Length>s2.Length then Swap(s1,s2);
  if pos(s1,s2)=0 then Write('не');
  Writeln(' входит в более длиное');
  // #4
  s1:=s1.ToCharArray.Select((c,i)->i mod 2<>0?'a'+c:c).JoinIntoString('');
  Writeln('Задание 4) ',s1);
  // #5
  Writeln('Задание 5) Сумма кодов (в UNICODE) для длинного слова: ',
      s2.ToCharArray.Select(c->integer(Ord(c))).Sum)
end.

Примеры
Первое слово: Колокольчик однозвучный утомительно звенит
Второе слово: дно
Задание 1) Колокольчик однозвучный утомительно звенит
Задание 3) Более короткое слово  входит в более длиное
Задание 4) дaно
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 42383

Первое слово: ссора
Второе слово: рессора
Задание 1) рессора
Задание 2) ссора
Задание 3) Более короткое слово  входит в более длиное
Задание 4) сaсоaра
Задание 5) Сумма кодов (в UNICODE) для длинного слова: 7589
ramzaev09
Для групповых операций с файлами
используются
маски имен файлов. Маска представляет собой
последовательность букв, цифр и прочих допустимых в именах файлов символов, в
которых также могут встречаться следующие символы: символ «?» (вопросительный
знак) означает ровно один произвольный символ; символ «*» (звездочка) означает любую последовательность символов
произвольной длины, в том числе «*» может задавать и пустую последовательность.

Определите,
какое из указанных имен файлов удовлетворяет маске: ?el*.t*xt.

A) spell.txt

B) pencil.text

C) el.txt

D) welcome.text

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика, 10 классрешите задачу стандартными методами Паскаля, без сложных функций. (без чар и орд)напишите программу которая выполняет шифрование строки с шифра цезаря​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

karavan85450
Sadikova Gavrikov
egorova90356684858370
tsypant
Васильева-Александрович
bellaalya13862
МуратМарина1140
srkushaev
Кулагина_Владимир1179
Alekseevna
osnickyi
gri-7410
Александровна-Павловна
Zheleznyakova
iraimironova