Напишите программу, которая получает с клавиатуры два натуральных числа и находит их НОД с алгоритма Евклида. Программа должна подсчитать количество шагов цикла. С
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Rewrite(f,'books.dat'); Writeln('Ввод данных по книгам'); var s1,s2:string; var i1,i2:integer; var book:tBook; repeat s1:=ReadlnString('Автор или * для окончания ввода:'); if s1<>'*' then begin s2:=ReadlnString('Название книги:'); i1:=ReadlnInteger('Количество страниц:'); i2:=ReadlnInteger('Год издания:'); (book.author,book.naim,book.pages,book.godizd):=(s1,s2,i1,i2); Write(f,book) end until s1='*'; Writeln('*** Ввод завершен ***'); f.Close end.
Тестовое решение Ввод данных по книгам Автор или * для окончания ввода: Жюль Верн Название книги: 80 тысяч километров под водой Количество страниц: 573 Год издания: 1951 Автор или * для окончания ввода: Сергей Лукьяненко Название книги: Дозор Количество страниц: 934 Год издания: 2004 Автор или * для окончания ввода: Жюль Верн Название книги: Властелин мира Количество страниц: 104 Год издания: 2011 Автор или * для окончания ввода: * *** Ввод завершен ***
2. Программа для выборки
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016 type tBook=record author:string[30]; naim:string[50]; pages:integer; godizd:integer end; begin var f:file of tBook; Reset(f,'books.dat'); var s:=ReadlnString('Автор книги:'); var y:=Readinteger('Год издания, не ранее:'); var k:=0; var book:tBook; while not f.Eof do begin Read(f,book); if (book.author=s) and (book.godizd>=y) then begin Writeln(book); Inc(k) end; end; if k=0 then Writeln('Таких книг не найдено'); f.Close end.
Тестовое решение Автор книги: Жюль Верн Год издания, не ранее: 2005 (Жюль Верн,Властелин мира,104,2011)
kalina1372
04.11.2022
1. Компьютерный вирус - это вредоносная программа, которая воспроизводить себя через компьютер или через компьютерные сети. Компьютер может заразиться вирусом через флешку, электронную почту или программы для обмена сообщениями.
2. Флешка, диск, интернет.
3. Уменьшение объема свободной оперативной памяти; замедление загрузки и работы компьютера; непонятные (без причин) изменения в файлах, а также изменения размеров и даты последней модификации файлов; ошибки при загрузке операционной системы; непонятные системные сообщения, музыкальные и визуальные эффекты и т.д.
4. Потеря программ, данных, стирание информации в системных файлах, выход из строя движущихся частей жесткого диска, уменьшение объёма памяти, зависание компьютера, и многое другое.
5. Не заходить на незнакомые сайты; регулярно проверять компьютер на наличие вирусов(использовать антивирус), не запускать незнакомые файлы.
6. Антивирус - это программа для обнаружения компьютерных вирусов. Виды антивирусов: сканеры, блокираторы, иммунизаторы.
#include <iostream>
using namespace std;
int NOD(int a, int b) {
int iter = 0;
if (a < b) {
swap(a, b);
}
while (a % b != 0) {
a = a % b;
swap(a, b);
iter++;
}
cout<<"NOD: "<< b << " Iteration: "<< iter;
}
int main()
{
int a,b;
cin>>a>>b;
NOD(a,b);
return 0;
}