Sknyajina5
?>

Напишите программу, которая вычисляет площади круга или квадрата. Программа должна содержать меню: 1) площадь круга, 2) площадь квадрата, 3) выход. При выборе одного из первых двух пунктов меню программа должна с необходимые данные для расчётов и вывести на экран значение соответствующей площади. Работа программы должна происходить до тех пор, пока пользователь не введет в меню цифру 3.

Информатика

Ответы

Кристина_Memmedov
Var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real;

procedure nod( var dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 :real; );
var a:array[1..6] of real;
i : integer;
begin
dv1:=100;
tr1:=100;
pt1:=100;
for i:= low(a) to high (a) do begin
readln(a[i]);
repeat
if( (a[i] mod 2) =0) then begin
a[i]:=a[i]/2;
dv:=dv+1;
end
else if( ( a[i] mod 3)=0) then begin
a[i]:=a[i]/3;
tr:=tr+1;
end
else if ( ( a[i] mod 5)=0) then begin
a[i]:=a[i]/5;
pt:=pt+1;
end;

untill(a=1);
if dvif trif ptdv:=0;
tr:=0;
pt:=0;
end;
if dv1>0 then dv2:=dv1*2 else dv2:=1;
if tr1>0 then tr2:=tr1*3 else tr2:=1;
if pt1>0 then pt2:=pt1*5 else pt2:=1;
nod:=dv2*tr2*pt2;
writeln(nod);
end;
begin
nod( dv,tr,pt,dv1,tr1,pt1,dv2,tr2,pt2 );
end.

end;
manuchar-formen2
Задача №1
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer; 
Begin                   
writeln ('Введите число');
readln(n);                                    
writeln('Делители числа:');  
for i := 1 to n div 2 do     
  if (n mod i) = 0 then begin 
    write(i,'  ');
  end;         
End.       

Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
  a, b, x, y, nod: integer;

begin
  writeln('Введите a,b');
  readln(a, b);
  x := a;y := b;
  while x <> y do
    if x > y
      then x := x - y
    else y := y - x;
  nod := x;
  writeln('NOD(', a, ',', b, ')=', nod);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вычисляет площади круга или квадрата. Программа должна содержать меню: 1) площадь круга, 2) площадь квадрата, 3) выход. При выборе одного из первых двух пунктов меню программа должна с необходимые данные для расчётов и вывести на экран значение соответствующей площади. Работа программы должна происходить до тех пор, пока пользователь не введет в меню цифру 3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Pastel-sova
membuksdk
мария Кузив1393
Бетті нөмірлеу үшін:кірістіру
rusart3
SaraevaTretyakov1941
dimaaristov
Виктория-Марина626
sochi-expert
kosbart28
Полковников_Милана
101110(2)-10-қа айналдыру​
margo929
yurkovam-037
ella440
avdushinalizza1
alf206