vladusha47713
?>

Библиотечный метод Продемонстрируйте работу метода сортировки вставками по возрастанию. Для этого выведите состояние данного массива после каждой вставки на отдельных строках. Если после рассмотрения очередного элемента массив не изменился, то его выводить не нужно. Если массив упорядочен изначально, то следует не выводить ничего. Входные данные На первой строке дано число N (1≤N≤100) — количество элементов в массиве. На второй строке задан сам массив: последовательность натуральных чисел, не превышающих 109. Выходные данные В выходной файл выведите строки (по количеству вставок) по N чисел каждая. Примеры Ввод 2 2 1 Вывод 1 2 Ввод 4 2 1 5 3 Вывод Формат вывода именно такой как в прмере

Информатика

Ответы

Дмитрий1974
1. При использовании палитры из 2^24 цветов для хранения цвета 1 пикселя используется 24 бита = 3 байта.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт = 
 20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт
sapelnikovk-74
Программа:
#include <iostream>
using namespace std; 
int main()
{
    int a=5;
    int b=4;
    int c;
    cout << "Количество яблок у Васи = " << a << "\n";
    cout << "Количество яблок у Пети = " << b << "\n";
    cout << "Количество яблок у Васи и Пети вместе = " << a+b << "\n";
    c=(a+b)/3;
    cout << "Если разделить на 3-х поровну, то получится = " << c << "\n";
    return 0;
}

Результат:
Количество яблок у Васи = 5
Количество яблок у Пети = 4
Количество яблок у Васи и Пети вместе = 9
Если разделить на 3-х поровну, то получится = 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Библиотечный метод Продемонстрируйте работу метода сортировки вставками по возрастанию. Для этого выведите состояние данного массива после каждой вставки на отдельных строках. Если после рассмотрения очередного элемента массив не изменился, то его выводить не нужно. Если массив упорядочен изначально, то следует не выводить ничего. Входные данные На первой строке дано число N (1≤N≤100) — количество элементов в массиве. На второй строке задан сам массив: последовательность натуральных чисел, не превышающих 109. Выходные данные В выходной файл выведите строки (по количеству вставок) по N чисел каждая. Примеры Ввод 2 2 1 Вывод 1 2 Ввод 4 2 1 5 3 Вывод Формат вывода именно такой как в прмере
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

larisau41
Maksim Lokhov
monenko
eoils-info
buff-studio
egcuzn86
tatasi
apioslk4533
avguchenkov
Сергеевна-С.А.1549
cometa94558
Bondarev_Ayupova795
bryzgalovag
alexseyzyablov
Shamil