?>
ПИТОН И С++ К-тая банка У Никиты есть n банок газировки, каждая из которых имеет свой объём. Известно, что полезнее всего пить газировку, начиная от банок большего объема и переходя к всё меньшим Никите найти k-ю по полезности банку. Встроенные алгоритмы сортировки не использовать. Входные данные В первой строке записаны два числа 1≤n≤105 и 1≤k≤103. Гарантируется, что k≤n. Далее в строке записаны n целых чисел 0≤ai≤2⋅109 — объёмы банок. Выходные данные Вывести объём k-ой в порядке полезности банки. Примеры Ввод Вывод 5 5 1 7 2 3 2 1
Ответы
//Pascal
const m = 1000
var
arr: array[1..m] of integer;
n,i, j, k: integer;
begin
readln(n);
write ('Исходный массив: ');
for i := 1 to n do begin
readln(arr[i]);
end;
//сортировка методом пузырька
for i := 1 to n-1 do
for j := 1 to n-i do
if arr[j] > arr[j+1] then begin
k := arr[j];
arr[j] := arr[j+1];
arr[j+1] := k
end;
write ('Отсортированный массив: ');
for i := 1 to n do
write (arr[i]:4);
end.
Алгоритм сортировки на классическом языке программирования С
# define SWAP(A,B) {A=A^B;B=A^B;A=A^B;}
void bubblesort(int A[], int n)
{
int i, j;
for(i = n-1 ; i > 0 ; i--)
{ for(j = 0 ; j < i ; j++)
{
if( A[j] > A[j+1] ) SWAP(A[j],A[j+1]);
}
}
}