АльбертовичБерезин58
?>

Написать программу для c++ и составить блок-схему Написать программу для c++ и составить блок-схему! ">

Информатика

Ответы

molodoychek
Всего 1508 цифр. начинаем с 4. тогда будем считать количество однозначных, двухзначных и трёхзначных номеров у страниц.
5, 6, 7, 8, 9 - всего 5, тогда 1508 - 5 = 1503 стр. не указал 4, так как на ней начинается первая глава. её и добавим с главами в конце.
теперь ряд 10, 11, 12 .. 97, 98, 99, в котором 90 двухзначных чисел, тогда
1503 - 90*2 = 1503 - 180 = 1323.
так как в ряду 100..999 много чисел, то просто разделим 1323 на 3 и получим 441.
теперь считаем
441(трёхзн) + 90(двухзн) + 5(однозн) + 3(нач) + 1(кон) + 6(главы) = 546 страница в книге.
sisychev
var 
a, b: integer;

begin 
write('Введите a: ');   
readln(a);   
write('Введите b: '); 
readln(b); 
var x := Range(a, b); 
writeln('Последовательность: '); 
x.Println; 
writeln('Ср. ариф. неотриц чисел: '); 
writeln(x.Where(x -> x >= 0).Average);
end.


var  a, b,i,s: integer;  k: real;

begin  
write('Введите a: ');    
readln(a);    
write('Введите b: ');  
readln(b); 
writeln('Последовательность: ');  
for i:=a to b do  write(i,' ');
writeln();
s:=0;
for i:=a to b do    
if i>=0 then begin   
s:=s+i;   
k:=k+1;
end;
writeln('Ср. ариф. неотриц чисел: '); 
write(s/k);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для c++ и составить блок-схему Написать программу для c++ и составить блок-схему! ">
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gordeevadesign2986
Budanov317
baranovaas
Суховодова599
rublevaoe392
РубенШафетдинов
koldunovan
yugraspets
evoque2014
delfinmos
zaotar2008
Karlova1507
Грачева мураховская
Андреевнатест707
emartynova25