aetolstih
?>

Написать программу на языке С (массивы) 1.Посчитать количество элементов массива, меньших 45 2.Найти среднее арифметическое элементов массива, меньших

Информатика

Ответы

kate281078

//Братишка, я тебе опять С++ принёс

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cout<<"Enter size of array\n";

   cin>>n;

   int *arr = new int;

   for(int i = 0;i<n;i++){

       cin>>arr[i];

   }

   int counter_of_less_fortyfive = 0;

   vector<int>seventyeight;

   for(int i = 0;i<n;i++){

       if(arr[i]<45){

           counter_of_less_fortyfive++;

       }

       if(arr[i]<78){

           seventyeight.push_back(arr[i]);

       }

   }

   int summ_seventyeight = 0;

   for(auto &i:seventyeight){

       summ_seventyeight+=i;

   }

   float average_seventyeight = summ_seventyeight / seventyeight.size();

   cout<<"Quantity of elements wich less then 45 is "<<counter_of_less_fortyfive<<endl;

   cout<<"Average of elements wich less 78 is "<<average_seventyeight;

   return 0;

}

kotovayaanastasia2069

Человеческое общество по мере своего развития овладевало не только веществом и энергией, но и информацией. С появлением и массовым рас компьютеров человек получил мощное средство для эффективного использования информационных ресурсов, для усиления своей интеллектуальной деятельности. С этого момента (середина XX века) начался переход от индустриального общества к обществу информационному, в котором главным ресурсом становится информация.

Возможность использования членами общества полной, своевременной и достоверной информации в значительной мере зависит от степени развития и освоения новых информационных технологий, основой которых являются компьютеры. Рассмотрим основные вехи в истории их развития.

Объяснение:

Нужно использовать декодер. Например этот:

https://www.artlebedev.ru/decoder/

Александрович_Викторовна

1. можно выделить лишь три основных вида алгоритмов (для краткости далее будем называть их линейные, разветвляющиеся и циклические алгоритмы):

• линейной структуры,

• разветвляющейся структуры,

• циклической структуры.

Линейный алгоритм – алгоритм, в котором порядок действий фиксирован и каждое действие выполняется только один раз.

Разветвляющаяся структура алгоритм, при выполнении которого каждый раз последовательность действий может быть разная. Схема подобного алгоритма обязательно содержит хотя бы один блок (символ) "решение", который и обеспечивает разветвление вычислительного процесса.

Алгоритм циклической структуры – это алгоритм, в котором предусмотрено неоднократное выполнение одной и той же последовательности действий. На практике часто встречаются задачи, в которых одно или несколько действий бывает необходимо повторить несколько раз.

2. Блок-схема — рас тип схем (графических моделей), описывающих алгоритмы или процессы, в которых отдельные шаги изображаются в виде блоков различной формы, соединенных между собой линиями, указывающими направление последовательности.

3. Псевдоко́д — компактный, зачастую неформальный язык описания алгоритмов, использующий ключевые слова императивных языков программирования, но опускающий несущественные для понимания алгоритма подробности и специфический синтаксис.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке С (массивы) 1.Посчитать количество элементов массива, меньших 45 2.Найти среднее арифметическое элементов массива, меньших
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

inbox466
tushina2020
Sidunevgeniya
yuliyastatsenko3894
nikiforovako76
kagurkina
ViktorovnaKraeva634
matterfixed343
tata-novik
Захаров-Иванович
ВладимировнаИП37
bolosolo77
sancity997124
victoriapetrs
vet30