Рис расфасован в два пакета. Масса первого — т кг, второго — п кг. Составить программу, определяющую: а) какой пакет тяжелее — первый или второй; б) массу более тяжелого пакета.
Program G; Uses Crt; Var count, num, ch: integer; Begin ClrScr; Writeln('Год високосный? 1 - да, 0 - нет'); Readln(Ch); If ch=1 then Begin Writeln('Введите номер месяца'); Readln(num); Сase num of 1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.'); 4, 6, 9, 11: writeln('В месяце 30 дней.'); 2: writeln('В месяце 29 дней'); else writeln('Некорректный ввод данных') End; End Else if ch=0 then Begin Writeln('Введите номер месяца'); Readln(num); Сase num of 1, 3, 5, 7, 8, 10, 12: writeln('В месяце 31 день.'); 4, 6, 9, 11: writeln('В месяце 30 дней.'); 2: writeln('В месяце 28 дней'); else writeln('Некорректный ввод данных') End; End Else writeln('Некорректный ввод данных'); Readln; End.
misterdre9991
16.04.2021
Может, все ЦИФРЫ чётные? Тогда смысл понятен. Будем считать это правильным условием. Тогда: program Chisla; var i,a,b,c,d:integer; BEGIN for i:=1000 to 9999 do begin a:=i div 1000; if a mod 2=1 then continue; //если первая цифра нечетная, переход на следующий виток цикла b:=(i div 100) mod 10; if b mod 2=1 then continue; //если вторая цифра нечетная, переход на следующий виток цикла c:=(i mod 100) div 10; if c mod 2=1 then continue; //если третья цифра нечетная, переход на следующий виток цикла d:=i mod 10; if d mod 2=1 then continue //если четвертая цифра нечетная, переход на следующий виток цикла else writeln(i); //иначе все цифры четные - выводим число i на экран end; //конец витка цикла END. //конец программы
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Рис расфасован в два пакета. Масса первого — т кг, второго — п кг. Составить программу, определяющую: а) какой пакет тяжелее — первый или второй; б) массу более тяжелого пакета.
Объяснение:
#include <iostream>
int main()
{
int F=3, S=5; //Масса первого — т =3 кг, второго — п =5 кг.
if(F>S) std::cout << "Первый тяжелее второго"<<std::endl<<"Его масса: "<< F;
else std::cout << "Второй тяжелее первого"<<std::endl<<"Его масса: " << S;
return 0;
}