MISAKOVNA49
?>

ОЧЕНЬ Составьте программу, которая реализуетввод с клавиатуры трех произвольныхположительных чисел а, b и c. Возводит вквадрат только нечетные числа, а четныеоставляет без изменения. Новые значениявыводит на экран.

Информатика

Ответы

Koranna1986
Уже отвечал, но все же такое решение актуальнее: 

var 
ar:array[1..10] of integer;
max,min,i,kmax,kmin:integer;
begin
randomize;

max:=0;
min:=1000;

for i:=1 to 10 do begin  
ar[i]:=random(1000)+1;  
if (ar[i] > max) then 
  begin max:=ar[i]; kmax:=i; end 
    else if (ar[i] < min) then begin min:=ar[i]; kmin:=i; 
end;  
write(ar[i],' ');
end;

writeln();

if (kmax > kmin) then for i:=kmin+1 to kmax-1 do write(i,' ') 
  else if (kmax < kmin) then for i:=kmax+1 to kmin-1 do write(i,' ');
end.

P.S. В решении выше есть далеко ни одна ошибка ;)
gernovoy

Натуральные числа - числа, используемые для счёта предметов. Не являются отрицательными, не являются дробными.

1)1*2=2

2)2*2=4

3)4*2=8

4)8*2=16

5)16*2=32

6)32*2=64

 

При сплошном умножении 62 не получится.

Попробем менять числа местами:

С шага 4) 16 > 61, 61*2=122

С шага 5) 32 > 23, 23*2=46, если 46*2 то будет 92. если 46 поменять местами то будет 64, оба варианта опять не подходят.

С шага 6) 64 > 46, если 46*2 то будет 92. если 46 поменять местами то будет 64, оба варианта опять не подходят.

 

ответ: получить из числа 1 число 62 на таком калькуляторе нельзя.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ОЧЕНЬ Составьте программу, которая реализуетввод с клавиатуры трех произвольныхположительных чисел а, b и c. Возводит вквадрат только нечетные числа, а четныеоставляет без изменения. Новые значениявыводит на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitriy2211104
Gulyaev_Egorkina
kettikis
yurazharov
Radikovnanikolaeva
household193
siren89
kitoova
denspiel
Вячеславовна_Сагитович
olkay
ali13zakup5064
verkop9
ГегамБукреев830
Iselickaya1890