layna1241383
?>

ПОМАГИТЕ СОСТАВИТЬ ПРОГРАММУ Visualstudio с использованием экранных форм.Составить программу , проверяющую, является ли введённое предложение « перевёртышем» , т.е. читающиеся одинаково слева на справо и справа на лево ( без разделителей, разумеется Примеры «перевёртышей» : аргентина манит негра, а роза упала на лапу азора.

Информатика

Ответы

de1979nis

RAW.

Формат файлов содержащий необработанную информацию, поступающую напрямую с матрицы фотокамеры. Эти файлы не обрабатываются процессором камеры (в отличие от JPG) и содержат оригинальную информацию о съемке. RAW может быть сжат без потери качества.

Преимущества RAW очевидны — в отличие от JPG, который был обработан в камере и уже сохранен с сжатием данных — RAW дает широчайшие возможности по обработке фотографии и сохраняет максимальное качество.

Заметка. Разные производители фототехники используют разные алгоритмы для создания RAW в своих камерах. Каждый производитель придумывает собственное разрешение для своего RAW-файла — NEF — Nikon, CR2 — Canon…

Olga_Vyacheslavovich1054

var

i, a, b, n, n2, j: longint;

s: string;

flag: boolean;

begin

Write('Введите через пробел границы диапазона: ');

Readln(a, b);

if b < a then begin n := a; a := b; b := n end;

if a < 11 then a := 11;

for i := a to b do

begin

Str(i, s);

n := Length(s); n2 := n div 2; flag := true; j := 1;

repeat

flag := (s[j] = s[n - j + 1]);

j := j + 1

until (not flag) or (j > n2);

if flag then Write(i, ' ')

end;

end.

Тестовое решение:

Введите через пробел границы диапазона: 800 1500

808 818 828 838 848 858 868 878 888 898 909 919 929 939 949 959 969 979 989 999

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ПОМАГИТЕ СОСТАВИТЬ ПРОГРАММУ Visualstudio с использованием экранных форм.Составить программу , проверяющую, является ли введённое предложение « перевёртышем» , т.е. читающиеся одинаково слева на справо и справа на лево ( без разделителей, разумеется Примеры «перевёртышей» : аргентина манит негра, а роза упала на лапу азора.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eremenkou
Гарик383
saltikovaK.S.1482
guujuu
Rizhov Alekyan325
mado191065
Кононова-БЕСКРОВНАЯ
gorovoy-dv4088
cholga69
Платон Демцун
Анатольевна824
lechic3
VolkovaMaslova
syana80
Kondratev Ruzavina22