nyuraborova89
?>

буду благодарен. (составить программу расчета количества ненулевых элементов матрицы P (6 * 7), элементы матрицы действительные числа)

Информатика

Ответы

ti2107
                                     PascalABC.NET                                      

С ручным заполнением матрицы:

beginvar P := ReadMatrReal(6, 7); Print('Количество ненулевых элементов:',P.ElementsByRow.Count(x->x<>0));end.

С рандомным заполнением матрицы:

beginvar P := MatrRandomReal(6, 7, -10, 10); P.Print; Print('Количество ненулевых элементов:',P.ElementsByRow.Count(x->x<>0));end.

Пример работы:


буду благодарен. (составить программу расчета количества ненулевых элементов матрицы P (6 * 7), элем
буду благодарен. (составить программу расчета количества ненулевых элементов матрицы P (6 * 7), элем
propercarwashes275
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}
melissa-80

Графический интерфейс (Graphical User Interface или GUI) создан для более удобного взаимодействия с пользователем (в отличии от просто командно-текстового взаимодействия или консоли)

Надпись, иконка - элементы для вывода информации текстовой и графической соответственноКнопка - базовый функциональный элемент для запуска определенной команды. Может содержать иконки и надписиТекстовое поле - одно/много-строчное, для вывода и ввода текстовой информации. Пункт меню - вариация кнопкиМеню - обычно древовидное объединение нескольких пунктов менюОбласти для вывода изображений и видеоКурсор мыши - элемент для удобного взаимодействия со всем вышеперечисленным

Не совсем точно, но более менее понятно. Так или иначе из комбинации этих элементов и состоят все графические интерфейсы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

буду благодарен. (составить программу расчета количества ненулевых элементов матрицы P (6 * 7), элементы матрицы действительные числа)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Вадимовна
TatiyanaBe20135263
КараханянКусков
hotel-info
olartamonov6
purchase
ski89439
Лоскутова
kokukhin
starabanov
jstepanova
nrostovtseva142
Барскова1943
Панков1101
Anzhelika-Bulanov802