avguchenkov
?>

Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.

Информатика

Ответы

tpomyleva6

Держи ;)

Var year,s,y,o:integer; old,young,name,nation:string;

Begin

s:=0;

o:=0;

y:=200;

While (s=0) do

Begin

Write('Введите имя и фамилию участника. Если список окончен, напишите "конец": ');

Readln(name);

If (name='конец') then break;

Write('Введите национальность участника: ');

Readln(nation);

Write('Введите возраст участника: ');

Readln(year);

If (year > o) and (nation='русский') then

Begin

o:=year;

old:=name;

end;

If (year < y) and (nation='русский') then

Begin

y:=year;

young:=name;

end;

end;

Write('Самый молодой русский участник - ',young,', самый старый русский участник - ',old);

End.

ganzashop

Начнём с того, что произведение цифр числа меньше двадцати не будет больше десяти. Первое число - 26, т.к. 2* 6 = 12.

А вообще, можно сделать проще.

Алгоритм звучит так:

икс = 10

Пока число(возьмем его за икс) > 9 и < 100:

   если первая цифра строки икс "string(x[0])" (или как-то так) умноженная на x[1] больше 10:

       вывести это число на экран

       прибавить к иксу еденицу

Уточню: насколько я знаю, разглядывать строку как массив позволяет только питон, есть другой Если вы учили преобразование одного типа в другой, вроде вещественного числа 1.23 в целое число (1 в данном случае), можно поделить икс на 10, преобразовать его обратно в целое число, это и будет первая цифра

Вторая цифра - это от икса отнять первую цифру, умноженную на 10.

Цикл "пока" - вроде-бы WHILE.

Ниже прикреплю код на питоне для примера, даже если это не то, что нужно, будет куда взглянуть.


Решить легкое на pascal! можно кратко! . на картинке! если не можете открыть , то !
yuliasam

(АСУ) , совокупность математических методов, технических средств (ЭВМ, средств связи, устройств отображения информации и т. д.) и организационных комплексов, обеспечивающих рациональное управление сложным объектом (процессом) в соответствии с заданной целью. АСУ состоит из основы и функциональной части. В основу входят информационное, техническое и математическое обеспечение. К функциональной части относят набор взаимосвязанных программ, автоматизирующих конкретные функции управления (планирование, финансово-бухгалтерскую деятельность и др.). Различают АСУ объектами (технологическими процессами - АСУТП, предприятием - АСУП, отраслью - ОАСУ) и функциональными автоматизированными системами, напр., проектирования, расчетов, материально-технического и др. обеспечения.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Николаевна
ayk111560
timsch12
kirillreznikov
andreyduborezz2913
Константиновна
autofilters27
Lusiarko65
X2755070
vakhitov100961
Lesya
sashakrotova943
bufetkonfet53
Azarenkoff
Дил1779