Nastyaches4
?>

Написать программу на языке программирования Pascal, вычисляющую значение функции. Значения А, В, С, х вводятся с клавиатуры.

Информатика

Ответы

tatk00
Можно быстро сообразить, какой будет ответ, при кругов Эйлера.

Всего есть 2^6 = 64 возможных комбинаций входных параметров и, соответственно, в таблице 64 строки. Изобразим области истинности выражений A и B. Область истинности выражения A + -B – это объединение области истинности A и области ложности выражения B; область истинности изображена на рисунке зелёным цветом.

Чтобы в закрашенную область попало как можно больше элементов, в незакрашенной области элементов должно быть как можно меньше. В данном случае ничего не мешает тому, чтобы в незакрашенной области вообще не было элементов, при этом все 5 элементов в области истинности B должны одновременно быть и в области истинности A. При этом в область истинности выражения A + -B входят все 64 элемента, максимально возможное число единиц равно 64.
Как решать эту и подобные . бывают ещё с минимальным числом. каждое из логических выражений a и b за
Goldaram84
С использованием if и switch.double uah;
int answer;
const double eur = 28.05;
const double usd = 26.74;
const double rub = 0.33;
cout << "Menu" << endl;
cout << "1 - EUR" << endl;
cout << "2 - USD" << endl;
cout << "3 - RUB" << endl;
cout << "0 - Exit" << endl;
cin >> answer;
switch (answer)
{
case 1:
cout << "Enter UAH:";
cin >> uah;
cout << uah / eur << " EUR" << endl;
break;case 2:
cout << "Enter UAH:";
cin >> uah;
cout << uah / usd << " USD" << endl;
break;case 3:
cout << "Enter UAH:";
cin >> uah;
cout << uah / rub << " RUB" << endl;
break;case 0:
exit(0);
break;default:
cout << "Error!" << endl;
break;}
system("pause");

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке программирования Pascal, вычисляющую значение функции. Значения А, В, С, х вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kv135549
kozak8824
adel25159
Yuliya Aleksandr686
annademidova-74
elenaneretina
борисовна Елена78
peshnoshamon
matoksana
xobby18
elenaowchinik4842
krimenu5033
Равиль_Евгеньевич1808
Zeegofer
hello