yanermarina87
?>

Перечень практических заданий 1. Написать программу, заполняющую массив четными числами от 1 до 51 и вывести его на экран.2. Написать программу, заполняющую массив нечетными числами от 1 до 61 и вывести его на экран.3. Имеется массив из 10 элементов, которые являются случайными числами в интервале от 1 до 100. Написать программу нахождения суммы элементов массива, которые делятся на 5, но не делятся на 2.4. Написать программу, заполняющую массив числами 1, 14, 19, 116, …1100 и вывести его на экран.5. Написать программу, осуществляющую ввод 10 элементов массива и выполняющую подсчет количества нулевых, отрицательных и положительных элементов.6. Составьте программу, рассчитывающую функцию:={2√3+322, <0., ≥0, 7. Составить программу, получающую при вводе два целых числа. Программа должна выводить слово yes, если остаток от деления первого числа на второе или второго на первое равен 1. Если остаток от деления первого числа на второе равен 2, то программа должна выводить слово yes+. Во всех остальных случаях программа должна выводить слово no.8. Составить программу, рассчитывающую значение функции =3+− на участке определения [-1;1] с шагом Δx=0, 2. Коэффициенты b, c вводятся с клавиатуры. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 2 знаков после запятой. Использовать оператор цикла repeat.9. Составить программу, рассчитывающую значение функции =32+2.5+4 на участке определения [-2;2] с шагом Δx=0, 5. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 1 знака после запятой. Использовать оператор цикла for.10. Составить программу , рассчитывающую количество цифр в целом числе n. Целое число n вводится с клавиатуры. Использовать операции целочисленного деления div и получения остатка от целочисленного деления mod. Результатом работы программы является число цифр.11. Написать программу вычисления суммы первых n элементов знакочередующегося степенного ряда:=1−1!+22!−33!+⋯+(−1)!12. Написать программу, осуществляющую подсчет количества слов в тексте. Слова в тексте разделены одним пробелом.13. Дано трехзначное целое число. Написать программу, определяющую наибольшую цифру числа.

Информатика

Ответы

rakitinat8

Если собака может загрызть козла тогда берём козла и собаку перевозим на другой берег там оставляем козла и забираем собаку обратно. На неачальном берегу оставляем собаку и капусту и забираем 2-ух волков. Везём волков к козлу оставляем волков на 2-ом берегу и забираем козу. Оставляем козу на начальном берегу и забираем капусту и собаку. Оставляем капусту вместе с волками а собаку  

забираем обратно едем к козе берём козу перевозим собаку и козу к 2-ум волкам и капусте. Всех перевезли. В кратце.

1) коза и собака

2) собака обратно 

3) 2 волка

4) коза обратно 

5) собака и капуста

6) собака обратно 

7) коза и собака

8) всё перевезли

katar050419735
Наверное имелось ввиду произведение его цифр, тогда может получиться так:

1. Решение без циклов
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var n,x,p: integer;//n1-кол-во четных, n2-нечетных
begin
  read(n);
  p:=1; 
 
//получаем остаток от деления (единицы) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем единицы
  n:=n div 10;
//получаем остаток от деления (десятки) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем десятки
  n:=n div 10;
//получаем остаток от деления (сотни) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем сотни
  n:=n div 10;
//получаем остаток от деления (тысячи) и умножаем на него p
  x:=n mod 10; p:=p*x;
//отбрасываем тысячи
 n:=n div 10;
///получаем остаток от деления (сотни тысяч) и умножаем на него p
 x:=n mod 10; p:=p*x;
// Теперь в p находится произведение единицы*сотни*тысячи*сотни тысяч

  writeln('Произведение цифр ',p);
end.

2. Решение с циклом

//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var n,x,p: integer;
begin
  readln(n);
  p:=1;
  while n>0 do  begin
  x:=n mod 10; p:=p*x;
  n:=n div 10;
  end;
  writeln('Произведение цифр ',p);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Перечень практических заданий 1. Написать программу, заполняющую массив четными числами от 1 до 51 и вывести его на экран.2. Написать программу, заполняющую массив нечетными числами от 1 до 61 и вывести его на экран.3. Имеется массив из 10 элементов, которые являются случайными числами в интервале от 1 до 100. Написать программу нахождения суммы элементов массива, которые делятся на 5, но не делятся на 2.4. Написать программу, заполняющую массив числами 1, 14, 19, 116, …1100 и вывести его на экран.5. Написать программу, осуществляющую ввод 10 элементов массива и выполняющую подсчет количества нулевых, отрицательных и положительных элементов.6. Составьте программу, рассчитывающую функцию:={2√3+322, <0., ≥0, 7. Составить программу, получающую при вводе два целых числа. Программа должна выводить слово yes, если остаток от деления первого числа на второе или второго на первое равен 1. Если остаток от деления первого числа на второе равен 2, то программа должна выводить слово yes+. Во всех остальных случаях программа должна выводить слово no.8. Составить программу, рассчитывающую значение функции =3+− на участке определения [-1;1] с шагом Δx=0, 2. Коэффициенты b, c вводятся с клавиатуры. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 2 знаков после запятой. Использовать оператор цикла repeat.9. Составить программу, рассчитывающую значение функции =32+2.5+4 на участке определения [-2;2] с шагом Δx=0, 5. Результатом работы программы является таблица со значениями аргумента и функции, выводящаяся с точностью до 2 знаков с точностью до 1 знака после запятой. Использовать оператор цикла for.10. Составить программу , рассчитывающую количество цифр в целом числе n. Целое число n вводится с клавиатуры. Использовать операции целочисленного деления div и получения остатка от целочисленного деления mod. Результатом работы программы является число цифр.11. Написать программу вычисления суммы первых n элементов знакочередующегося степенного ряда:=1−1!+22!−33!+⋯+(−1)!12. Написать программу, осуществляющую подсчет количества слов в тексте. Слова в тексте разделены одним пробелом.13. Дано трехзначное целое число. Написать программу, определяющую наибольшую цифру числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tsatskina857
mikhailkirakosyan
Arutyunovich
mupmalino2653
anton-www1
tatasi
kategar
baumanec199613
margo929
gostivdom302
billl24
andrewa
ElenaEgorova1988576
mail5
alexluu33