?>
1 Продумать математическую постановку задачи. 2 Составить программу решения задачи. 3 Отладить программу на компьютере. 4 В отчете привести исходные данные и результаты расчетов. Создать массив, содержащий возраст жителей дома. Определить возраст самого пожилого жителя и количество несовершеннолетних жителей дома
Ответы
#include <cstdlib>
// содержит srand() и rand()
#include <ctime>
using namespace std;
int main()
{
int n=10;
int mas[n] = {};
int tmp,j=0;
cout<<"random number";
cout<<endl;
// начальная установка генератора случ. чисел
srand(time(NULL));
// заполнение массива случайными числами
for (int i = 0; i < n; i++)
{
mas[i] = rand()/100; cout<<mas[i]<<" ";
}
cout<<endl;
// перестановка элементов
for (int i = 0; i < n/2; i++)
{
tmp=mas[i]; mas[i]=mas[2*(i+1)-1]; j=2*i;
while (j>i)
{
mas[j+1]=mas[j]; j--;
}
mas[i+1]=tmp;
}
//"массив после замены"
for (int i = 0; i < n; i++) cout<<mas[i]<<" ";
cout<<endl;
system("pause");
return 0;
}