mar77873
?>

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 24: var i, k: integer; function F(x:integer):integer; begin F:=x*x*x; end; begin i := 12; readln(K); while (i>0) and (F(i) > K) do i:=i-1; writeln(i); end.

Информатика

Ответы

muravlev2702

uses crt;
var
a:array[1..7,1..10] of integer;
b,i,j:integer;
begin
clrscr;
randomize();

//заполнение массива случайными числами

for i:=1 to 7 do
for j:=1 to 10 do
begin
a[i,j]:=random(10);
end;

//вывод массива

for i:=1 to 7 do
begin
for j:=1 to 10 do
write(a[i,j]:3,' ');
writeln();
writeln();
end;

//удаляем строку 6 и меняем 5 и 2 строки местами

for j:=1 to 10 do
begin
a[6,j]:=a[7,j];
a[7,j]:=0;
b:=a[5,j];
a[5,j]:=a[2,j];
a[2,j]:=b;
end;
writeln('Отредактированный массив');
//выводим отредактированный массив
for i:=1 to 6 do
begin
for j:=1 to 10 do
write(a[i,j]:3,' ');
writeln();
writeln();
end;
readln();
end.

samiramoskva
//прога на Pascal`e
const
n = 10;
var 
a: array of shortint;
i, min, sumcount: shortint;
sum: integer;
begin
randomize;
setLength (a, n);
writeln ('Исходный массив:');
for i:=0 to n-1 do
begin
a[i]:=random (101)-50;
write (a[i], '; ');
if a[i] in [10..15] then begin
inc (sum, a[i]); inc (sumcount); end;
if a[i]<a[min] then min:=i;
end;

if min<>(n-1) then
begin
a[min]:=a[min]+a[n-1];
a[n-1]:=a[min]-a[n-1];
a[min]:=a[min]-a[n-1];
end;
writeln ();
if sumcount>0 then
writeln ('CA чисел в промежутке [10..15]: ', sum/sumcount)
else writeln ('Нет чисел в промежутке [10..15]');
writeln ('Удален элемент a[', min+1, '] = ', a[n-1], '; измененный массив:');
setlength (a, n-1);
for i:=0 to n-2 do write (a[i], '; ');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 24: var i, k: integer; function F(x:integer):integer; begin F:=x*x*x; end; begin i := 12; readln(K); while (i>0) and (F(i) > K) do i:=i-1; writeln(i); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Golubovskayairina
Борисович409
mel9152480522
astahova
БеляковаСтаниславовна
Anzhelika-Bulanov802
mulyugina365
Меладзе_Владимир1695
Irina Svetlana
Donat-Evgeniya793
vifslafes
TrofimovAnastasiya828
Lilykl
anastasiya613
natkuv7