knigi21212
?>

Pascal ABC. Составьте программу табулирования функции y=x^2*ctg(x) +arcsin^2(x^2) на отрезке[0, 1] и с шагом 0, 1

Информатика

Ответы

ivanovk3599

хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз хз

dimaproh

class Node:

   def __init__(self, val):

       self.l = None

       self.r = None

       self.v = val

class Tree:

   def __init__(self):

       self.root = None

   def getRoot(self):

       return self.root

   def add(self, val):

       if self.root is None:

           self.root = Node(val)

       else:

           self._add(val, self.root)

   def _add(self, val, node):

       if val < node.v:

           if node.l is not None:

               self._add(val, node.l)

           else:

               node.l = Node(val)

       else:

           if node.r is not None:

               self._add(val, node.r)

           else:

               node.r = Node(val)

   def find(self, val):

       if self.root is not None:

           return self._find(val, self.root)

       else:

           return None

   def _find(self, val, node):

       if val == node.v:

           return node

       elif (val < node.v and node.l is not None):

           return self._find(val, node.l)

       elif (val > node.v and node.r is not None):

           return self._find(val, node.r)

   def deleteTree(self):

       # garbage collector will do this for us.  

       self.root = None

   def printTree(self):

       if self.root is not None:

           self._printTree(self.root)

   def _printTree(self, node):

       if node is not None:

           self._printTree(node.l)

           print(str(node.v) + ' ')

           self._printTree(node.r)

#     3

# 0     4

#   2      8

tree = Tree()

tree.add(3)

tree.add(4)

tree.add(0)

tree.add(8)

tree.add(2)

tree.printTree()

print(tree.find(3).v)

print(tree.find(10))

tree.deleteTree()

tree.printTree()

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal ABC. Составьте программу табулирования функции y=x^2*ctg(x) +arcsin^2(x^2) на отрезке[0, 1] и с шагом 0, 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

манукян29
mashumi2170
rykovatv6
Apresov
kassel1b
mail66
Elshel8694
smalltalkcoffee5
predatorfishing608
Ионов202
Borshchev1820
missbuhgalter2013
Дружинин
lenalevmax7937
makscska22879