mkrtchyananaida6995
?>

ниже представлено условие задачи, по представить решение в паскале. Дан двумерный массив целых чисел. Написать программу, которая для каждой строки массива находит среднее арифметическое элементов, у которых последняя цифра нечетная.

Информатика

Ответы

Ohokio198336

В современной школе информатика – достаточно сложный предмет для усвоения учащимися. Основное препятствие для полноценного изучения информатики – нехватка времени. Мною проанализировано много учебных планов и методик преподавания информатики и для общеобразовательных классов, и для профильных с углубленным изучением информатики. Вывод неутешителен. Предлагаемые материалы основываются на гораздо большем годовом количестве учебных часов, чем то, которым мы реально располагаем. Следствием расхождения между рекомендуемым и реальным объемом учебных часов является невозможность использовать в процессе обучения какой-то один учебник информатики. Это неудобно как ученикам, так и преподавателю. Выходом из этой ситуации является разработка собственной методики преподавания информатики с ориентацией на творческую деятельность учащихся и тестовый контроль, которая, не уменьшая объем материала, позволяла бы сократить время на его усвоение учениками и уложиться в отведенное количество часов.

Основываясь на своем опыте работы с учащимися старшего звена, я выделила несколько основных тем, без усвоения которых невозможно успешное изучение всего курса информатики, и разработала собственную методику их преподавания. Я пользуюсь ей уже несколько лет, что позволяет добиваться хороших результатов в освоении учениками моего предмета. С методикой преподавания одной из таких тем я и хочу познакомить вас.

Секрет могущества ЭВМ – высокая скорость и большая память. Для записи алгоритмов, работающих с большими объемами информации, в алгоритмическом языке существуют специальные табличные величины (или просто таблицы). Исполнение многих алгоритмов было бы просто невозможно, если бы соответствующие объекты не были каким-либо образом организованы: упорядочены, классифицированы, занумерованы и так далее. Итак, нужно уметь организовать не только действия, но и те объекты, над которыми эти действия производятся.

Необходимо отметить, что таблицы (массивы) как основное средство представления однородной информации неизбежно используются во всех реальных компьютерных программах. На табличном принципе основана и архитектура современных ЭВМ: память машины можно рассматривать как большой массив байтов, адреса которых располагаются по возрастанию.

moonligh3560
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var a,n,k,i,j,s:integer;
begin
  writeln('Количество учеников и количество оценок');
  readln(n,k);
  for i:=1 to n do begin
    for j:=1 to k do begin
      write('Ученик № ',i, ' оценка № ',j,' = ');
      readln(a);
      s:=s+a;
    end;
  end;
  println('Средняя оценка группы ',s/(n*k):6:3);
end.

Тестовое решение:
Количество учеников и количество оценок
3 3
Ученик № 1 оценка № 1 = 3
Ученик № 1 оценка № 2 = 4
Ученик № 1 оценка № 3 = 4
Ученик № 2 оценка № 1 = 5
Ученик № 2 оценка № 2 = 4
Ученик № 2 оценка № 3 = 4
Ученик № 3 оценка № 1 = 4
Ученик № 3 оценка № 2 = 3
Ученик № 3 оценка № 3 = 3
Средняя оценка группы  3.778

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

ниже представлено условие задачи, по представить решение в паскале. Дан двумерный массив целых чисел. Написать программу, которая для каждой строки массива находит среднее арифметическое элементов, у которых последняя цифра нечетная.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

u-bhank
litlenet
kirillreznikov
alex6543213090
daryagulyaeva
elmiro4ka868617
Воздвиженская
ekkim310
samsakovs7757
Lapushkin1988
shtankosoyuz1629
Shurshilina850
Тинчурина1528
steff77
academycoffee243