ars-trushakova
?>

Написать программу вычисления десяти значений функции y=(х+3)/5х, если х изменяется от 1 до с шагом 2, 4

Информатика

Ответы

Drugov_Vladimirovna

пару минут

Объяснение:

Mikhailovna_Litvinova276

Значение дроби можно вычислять так: начинаем с e = 0, затем обновляем значение e по формуле n / (n + e), уменьшая n, пока не получим 2 / (2 + ...). В конце прибавим к результату 2. Пример:

0\to \dfrac4{4+0}\to \dfrac3{3+\dfrac4{4+0}}\to\dfrac2{2+\dfrac3{3+\dfrac4{4+0}}}\to2+\dfrac2{2+\dfrac3{3+\dfrac4{4+0}}}

Все скучные операции с дробями оставим питону, пусть считает сам - у него для этого есть модуль fractions.

Знаменатели растут очень быстро - уже начиная с числа 13 знаменатель будет больше миллиарда.

Код (Python 3):

from fractions import Fraction

from itertools import count

n = int(input())

for k in count(3):

   e = Fraction(0)

   while k >= 2:

       e = k / (k + e)

       k -= 1

   e += 2

   a, b = e.numerator, e.denominator

   if b > n:

       print(a, b)

       break

Пример ввода:

1000000000

Пример вывода:

6706022400 2467007773

An-solomon

Объяснение:

Датчики ультразвукового излучения используются для обнаружения объектов, контроля их движения и измерения расстояний до них. Принцип действия состоит в следующем. Прибор излучает звуковые колебания с частотой больше 20000 герц. При встрече с объектом они отражаются, попадают в приемник, и фиксируется. Электронная схема отсчитывает время, которое с момента импульса до момента приема эха. Расстояние высчитывается по формуле: R= tV/2, где t – время между импульсом и приемом эха, V — скорость звука. Произведение делится на 2, потому что звуковые волны проходят путь, равный двойному расстоянию между объектом и датчиком. Скорость звука в различных средах неодинаковая: в воздухе это 331 м/сек, в дереве –1500, в воде – 1430.

Расстояние, на котором обнаруживаются объекты – до 8 метров, при условии, что у них твердая и гладкая поверхность. Если они изготовлены из мягкого, пористого материала, поглощающего звук – расстояние сокращается.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления десяти значений функции y=(х+3)/5х, если х изменяется от 1 до с шагом 2, 4
Ваше имя (никнейм)*
Email*
Комментарий*