zabrodin
?>

Мне нужно написать программы на Python: 1) Описать структуру с именем NOTE, содержащую следующие поля: • фамилия, имя; • номер телефона; • дата рождения (массив из трех чисел Написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив, состоящий из восьми элементов типа NOTE (записи должны быть упорядочены по дате рождения); • вывод на экран информации о человеке, номер телефона которого введен с клавиатуры (если такого нет, вывести соответствующее сообщение).

Информатика

Ответы

fancy-decor67

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

#include <stdio.h>

#include <math.h>

#include <string.h>

#include <iostream>

int main(void) {

   struct NOTE {

       char name[100];

       char family[100];

       int tele[15];

   };

   

   struct NOTE note[5];

   

   int i;

   

   

   

   for(i=0;i<5;i++) {

       printf("note %d:\n",i);

       printf("name?: "); scanf("%s",&note[i].name);

       printf("family?: "); scanf("%s",&note[i].family);

       printf("telephone?: "); scanf("%d",&note[i].tele);

   }

   int z[15];

   printf("telephone: ");scanf("%d",z[]);

   for(i=0;i<5;i++)

       if (strcmp(note[i].tele,z)==0){ //<ТУТ СЦУКА РУГАЕТСЯ,НЕ ПОЙМУ ПОЧЕМУ ХЛП

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   char t[40];

   printf("name: "); scanf("%s",t);

   for(i=0;i<5;i++)

       if (strcmp(note[i].name,t)==0){

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   

   return 0;

}

Объяснение:

mariashapar

Ну для начала давайте с первой разберёмся.

Начинать можно по-разному, но я всегда ищу точки, которые имеют какое-то отличие. Здесь же прям такого отличия нет.

Возьмём точки из которых идёт 4 дороги. У нас их две.

Г и Б, определить где какая тоже очень просто.

Поработаем с точкой Б. Из нее дорога идёт в пункт "В", из которого всего 2 пути (в Б, в И) Нам это уже дает подсказку, если мы пойдем из точки Б, то мы должны придти в пункт, из которого ведёт всего 2 дороги.

Перебираем все возможные варианты, ну у нас их всего 2. И получаем, что П5 это Б, а П1 это Г.

Дальше пойдём например от точки "В", из нее ведет всего 2 дороги, в Б и в И, следовательно, смотрим по таблице и определяем, что П3 это И.

В пункт Д ведут дороги из Б и из И, номера этих пунктов нам уже известно, опять же определяем по таблице, что это пункт П8.

Теперь мы знаем, где находится пункт "Д", а еще мы знаем, где пункт "Г".

Так определим пункт "Ж" аналогично тому, что я делал выше.

С пунктами "А" и "Е" аналогично.

ответ у нас будет такой: ГВИАБЖЕД

Окей, с первым разобрались, теперь переходим ко второму.

Здесь есть то, про что я говорил в начале своего ответа, точка, которая выделяется среди остальных. Это точка "Д"

только из нее выходит 4 дороги. Ну тут это даже не так важно, так как мы пойдем не таким

Какие точки у нас не ведут в Д? Это точки А и В.

Мы знаем, что они обе ведут в одну и туже точку, а такая есть только одна, легко определяем точку Г это у нас П6.

Теперь читаем условие "длина дороги АГ меньше, длины дороги ВГ", смотрим по таблице, ищем короткую дорогу и видим, что из П7 в Г дорого короче, следовательно, П7 это пункт А. Ну а пункт В это П3. Зная, сколько дорог ведет из пунков В и Г, мы определяем пункт Е, он у нас получается П1.

Ну а из пункта Е запросто находим пункт Ж и дорогу между ними. И наш ответ 24.


нужна с заданием 11 класса. Желательно с объяснением чтоб самому понять.
нужна с заданием 11 класса. Желательно с объяснением чтоб самому понять.
mila-vsv

Объяснение:

1. Оператор обязан сообщить в порядке, предусмотренном статьей 14 настоящего Федерального закона, субъекту персональных данных или его представителю информацию о наличии персональных данных, относящихся к соответствующему субъекту персональных данных, а также предоставить возможность ознакомления с этими персональными данными при обращении субъекта персональных данных или его представителя либо в течение тридцати дней с даты получения запроса субъекта персональных данных или его представителя.

2. В случае отказа в предоставлении информации о наличии персональных данных о соответствующем субъекте персональных данных или персональных данных субъекту персональных данных или его представителю при их обращении либо при получении запроса субъекта персональных данных или его представителя оператор обязан дать в письменной форме мотивированный ответ, содержащий ссылку на положение части 8 статьи 14 настоящего Федерального закона или иного федерального закона, являющееся основанием для такого отказа, в срок, не превышающий тридцати дней со дня обращения субъекта персональных данных или его представителя либо с даты получения запроса субъекта персональных данных или его представителя.

3. Оператор обязан предоставить безвозмездно субъекту персональных данных или его представителю возможность ознакомления с персональными данными, относящимися к этому субъекту персональных данных. В срок, не превышающий семи рабочих дней со дня предоставления субъектом персональных данных или его представителем сведений, подтверждающих, что персональные данные являются неполными, неточными или неактуальными, оператор обязан внести в них необходимые изменения. В срок, не превышающий семи рабочих дней со дня представления субъектом персональных данных или его представителем сведений, подтверждающих, что такие персональные данные являются незаконно полученными или не являются необходимыми для заявленной цели обработки, оператор обязан уничтожить такие персональные данные. Оператор обязан уведомить субъекта персональных данных или его представителя о внесенных изменениях и предпринятых мерах и принять разумные меры для уведомления третьих лиц, которым персональные данные этого субъекта были переданы.

4. Оператор обязан сообщить в уполномоченный орган по защите прав субъектов персональных данных по запросу этого органа необходимую информацию в течение тридцати дней с даты получения такого запроса.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Мне нужно написать программы на Python: 1) Описать структуру с именем NOTE, содержащую следующие поля: • фамилия, имя; • номер телефона; • дата рождения (массив из трех чисел Написать программу, выполняющую следующие действия: • ввод с клавиатуры данных в массив, состоящий из восьми элементов типа NOTE (записи должны быть упорядочены по дате рождения); • вывод на экран информации о человеке, номер телефона которого введен с клавиатуры (если такого нет, вывести соответствующее сообщение).
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ekaizer
Вадимовна
mantseva
Feyruz90
prostopo4ta29
samogon-mozhaisk
Aleksandrovich_Mitoyan1138
zigrin
MDubovikov73
onboxru16
galustyanvitaly4842
prianik6
Dmitrievich1871
lebedevevgen
Kuznetsova702