betepah
?>

Написать программу в паскале из диапазона от 10 до 1000 компьютер выбрал случайным образом число. если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное пк и новое, полученное после перестановки цифр. в противном случае, вывести выбранное пк число

Информатика

Ответы

magazin3000

var x,x1,x2,x3: integer; //x1- 1 число, х2- 2 число, х3 - 3 число

begin

  randomize;

  x: =random(1000)+10;

  if x div 100 > 0 then begin x1: =x div 100;

                                          x2: =(x mod 100) div 10;

                                          x3: =(x mod 100) mod 10;

                                          writeln(x,', ',x3,x2,x1);

                                  end

                          else writeln(x);

end.

     

 

манукян29

ответ:

номер 1-интернет - всемирная паутина, которая хранит в себе тонны информации. он заменяет нам любой источник информации и облегчает понимание.

газеты/журналы - письменные, или же стандартные способы получения информации на бумаге.

телевидение - самый удобный источник информации. содержит в себе и картинку, и звук, и приятную визуализацию.

постеры/афиши - бумажки расклеенные по городу или же огромные постеры размещенные на зданиях. привлекает внимание, тем самым увеличивает число интересующихся.

радио - звуковая информация, уже перестает быть актуальной. в основном, радио - это не новости, а что-то более развлекательное.

номер 2-к примеру, кто-то описывает картину на бумаге (повествованием), тем самым переводит графическую информацию в текстовую. рассказывает вслух - уже в звуковую. и т. д.

номер 3-написание дипломного  проекта  из  своего  же  курсового,  время  прошло  законы  изменились  и  теперь  за  одни  и  теже  административные  проступки  другие  наказания, но  дабы  не  писать с  нуля все  это  лучше  обработать  свой  же  курсовик  соответственно  изменив  его  содержание

номер 4-молекула днк  

              оптические носители  

              египитские папирусы  

              бумага

             

Litvin_Ivanov
Const c: array [1..10] of integer = (-7,3,0,2,-1,4,8,-9,1,6); var b,d: array [1..10] of integer;       p,k,max,i,j,tmp: integer; begin   p: =1;   for i: =1 to 10 do     if c[i] > 0 then p: =p*c[i];   k: =0;   for i: =1 to 10 do     if c[i] < 0 then inc(k);   d: =c;   max: =d[1];   for i: =2 to 10 do     if c[i] > max then max: =c[i];   writeln ('max: ',max);   writeln ('kol-vo otriz. elementov: ',k);   writeln ('proizvedenie: ',p);   for i: =1 to 10 do     if c[i] > = 0 then b[i]: =c[i]+10 else       if c[i] < 0 then b[i]: =c[i]*c[i];   writeln ('new massiv: ');   for i: =1 to 10 do write (b[i],' ');   writeln;   for i: =1 to 9 do     for j: =i+1 to 10 do       if d[j] > d[i] then         begin           tmp: =d[j];           d[j]: =d[i];           d[i]: =tmp;         end;     for i: =1 to 10 do write (d[i],' ');   writeln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале из диапазона от 10 до 1000 компьютер выбрал случайным образом число. если выбранное число является трехзначным, то поменять местами первую и последнюю цифры, выдать на печать число, выбранное пк и новое, полученное после перестановки цифр. в противном случае, вывести выбранное пк число
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tatgri
Нозадзе_Новиков392
bondarev05071962
podenkovaev314
jstepanova
victoriadan
ПодлеснаяМакарова1883
Дементьева-Артем1315
Veronika1270
Головин662
Avdeeva Inga1505
clubgarag701
iriska-669
is926582086060
Sinelnikov1650