Kashtelyan Tamara847
?>

Напишите код в Python Вдоль прямой выложены три спички. Необходимо переложить одну из них так, чтобы при поджигании любой спички сгорали все три. Для того чтобы огонь переходил с одной спички на другую, необходимо чтобы эти спички соприкасались (хотя бы концами Требуется написать программу, определяющую, какую из трех спичек необходимо переместить.

Информатика

Ответы

airon-082054

ответ:include <iostream>

#include <stdio.h>

#include <cstring>

using namespace std;

int main (){

int length,i,j,kol=0;

char vowel []="AEIOUY";

char text [100];

gets (text); //функция считывает все введённые символы с пробелами до тех пор, пока не будет нажата клавиша Enter

length=strlen (text);

for (j=0; j<=5; j++){

for (i=0; i<=length; i++)

if (text[i]==vowel[j])//сравниваем введённые элементы с заданными значениями строки

kol=kol+1cout << kol << endl return 0;

Объяснение:

Эти значение строки.

A E I O и Y остальные считаются согласными

Сумарокова
#include <iostream>
using namespace std;

string evenOrOdd(int n)
{
if (n % 2 == 0) {
return "чётное";
}
else {
return "нечётное";
}
}

string digitCount(int n)
{
if ( (int) n / 1000 > 0 ) {
if (n > 9999){
return "n-значное";
}
else {
return "четырёхзначное";
}
}
else if ( (int) n % 1000 / 100 > 0 ) {
return "трёхзначное";
}
else if ( (int) n % 100 / 10 > 0 ) {
return "двузначное";
}
else {
return "однозначное";
}
}

int main()
{
int n;
cout << "n = ";
cin >> n;
cout << evenOrOdd(n) << ' '
<< digitCount(n) << ' '
<< "число" << endl;
return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите код в Python Вдоль прямой выложены три спички. Необходимо переложить одну из них так, чтобы при поджигании любой спички сгорали все три. Для того чтобы огонь переходил с одной спички на другую, необходимо чтобы эти спички соприкасались (хотя бы концами Требуется написать программу, определяющую, какую из трех спичек необходимо переместить.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dimiff5
tomogradandrey
vladburakoff5
vasilevich-F
Drugov_Vladimirovna
Adabir20156806
uuks2012
Viktor1316
koptevan6
Ирина-Макаркина253
zaseche99
gorbelena1971
Tipan77
Pona4ka93
mihalevskayat