nkaminskaja
?>

СОСТАВИТЬ ВЫЧИСЛЕНИЕ В PASCAL: Составить программу вычисления функции на языке PASCAL:

Информатика

Ответы

lovely138887

// PascalABC.NET 3.6.3

begin

 var x := ReadReal;

 var y := if x >= -1 then Sqrt(x + 4)

   else if x < -4 then 2 * x + 5

   else 3 * x;

 Print(y)  

end.


СОСТАВИТЬ ВЫЧИСЛЕНИЕ В PASCAL: Составить программу вычисления функции на языке PASCAL:
victors
# 1

list = []

while True:

   n = int(input("nb: "))

   if n == 0:

       break

   list.append(n)

res = 1

sum = sum(list)

for x in list:

   if x * x > sum:

       res *= x

print(res)

# 2

def isPerfectSquare(num):

   s = int(num**0.5)

   return s * s == num

def isFibonacciNumber(n):

   return isPerfectSquare(5 * n * n + 4) or isPerfectSquare(5 * n * n - 4)

list = []

while True:

   n = int(input('nb : '))

   if n % 2:

       odd = n

       break

   list.append(n)

if isFibonacciNumber(n):

   print([x for x in list if not(x % 3)])

else:

   print([x for x in list if not(x % 5)])

# 3

list = []

N = int(input('N = '))

for i in range(N):

   n = int(input('nb : '))

   list.append(n)

print(sum([x for x in list if x * x % 10 == 9]))


Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
Решить 3 и 1\2 задачу ) Написать программы на языке программирования Python: 1) С клавиатуры вводятс
happygal5224

class Program

 {

   static void Main(string[] args)

   {

     string src = " Qwy. ... Asdf.. Lkjdfs A.";

     //string dest = ReplaceDots(src, '.', '…', 3);

     string dest = ReplaceDots(src, '.', "...", 3);

 

     Console.WriteLine("src:\t" + src);

     Console.WriteLine("dest:\t" + dest);

 

     Console.WriteLine();

     Console.Write("Press any key for exit ...");

     Console.ReadKey(true);

   }

 

   //private static string ReplaceDots(string src, char dotCh, char dots, int minDotsCount)

   private static string ReplaceDots(string src, char dotCh, string dots, int minDotsCount)

   {

     StringBuilder dest = new StringBuilder();

 

     int i = 0;

     while (i < src.Length)

     {

       int dotsCount = 0;

       while (i < src.Length && src[i] == dotCh)

       {

         dotsCount++;

         i++;

       }

 

       if (dotsCount >= minDotsCount)

         dest.Append(dots);

       else if (dotsCount == 0)

         dest.Append(src[i++]);

       else

         while (dotsCount-- > 0)

           dest.Append(dotCh);

     }

 

     return dest.ToString(); ;

   }

 }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

СОСТАВИТЬ ВЫЧИСЛЕНИЕ В PASCAL: Составить программу вычисления функции на языке PASCAL:
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Алексеевич620
Vip2002www86
julya847
bmargarita
opscosmiclatte7868
palmhold578
ti2107
olimov9
Vitalevna
aaazovcev
КириллЕгорова1906
olegmgu1
Михаил1121
Andreevich440
nkaminskaja
▲