2-ое задание:
#include <iostream>
int main() {
int number;
std::cout << "Введите число: " << std::endl;
std::cin >> number;
if (number > 0)
std::cout << "Положительное" <<std::endl;
else if (number < 0)
std::cout << "Отрицательное" << std::endl;
else
std::cout << "Ноль" << std::endl;
return 0;
}
1-ое задание:
#include <iostream>
int main() {
double dollars, grivnas;
std::cout << "Введите кол-во долларов: " << std::endl;
std::cin >> dollars;
grivnas = dollars * 28.3;
std::cout << dollars << " доллар-(а, ов) в гривнах " << grivnas << std::endl;
return 0;
}
Объяснение:
#include <iostream>
#include <vector>
using namespace std;
int am_dig(int k){
int res = 0;
while(k > 0){
res++;
k /= 10;
}
return res;
}
double average(vector<double> a){
double sum = 0;
for(auto i: a)
sum += i;
return sum/a.size();
}
int main() {
vector<double> a;
double x = 1;
while(x != 0){
cin >> x;
if(am_dig(x) == 3)
a.push_back(x);
}
if(a.size() == 0)
cout << "NO";
else
cout << average(a);
}
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу на C++ для решения следующей задачи. Дан массив А, состоящий из 10 действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран.
#include <iostream>
#include <vector>
using namespace std;
void swap(int *a, int *b){
int temp = *a;
*a = *b;
*b = temp;
}
signed main() {
const int n = 10;
vector<int> a(n);
int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;
for(int k = 0; k < n; k++){
cin >> a[k];
if(a[k] > mx){mx = a[k]; i = k;}
if(a[k] < mn){mn = a[k], j = k;}
}
swap(a[i],a[j]);
for(auto &i:a)
cout << i << " ";
}