Yurevna_Kharkchinov1302
?>

нужно написать программу Вычислить: 10 S=å(xi3+8)0.5 , где xi=xi-1+dx2; x1=2; dx=0.2. i=1

Информатика

Ответы

websorokin
program name;
var i,n,x,summa,count:integer;
nechet:boolean;
begin
Writeln('Vvedite n: ');
readln(n);//получаем n
summa:=0;
count:=0;
i:=1;
if(n mod 2 = 1) then nechet := true else nechet := false; //проверяем четное число или нет
while i<n do begin//пока число меньше n
if(nechet) then//если число нечентное
begin
summa:=summa+i*i*i;//прибавляем к сумме куб этого числа
end
else//если число четное
begin
summa:=summa+i*i;//прибавляем квадрат числа
end;
i:=i+1;//прибавляем число на 1
end;
writeln(' summa: ', summa);//выводим сумму
readln();
end.
spec-nt

Задача 1:

const N = 15;

const MAX = 15;

const MIN = -15;

var A: array [1..N] of integer;

var i,s1,s2: integer;

begin

randomize();

s1:=0;

s2:=0;

writeln('Исходный массив: ');

for i:=1 to N do

 begin

 A[i]:=random(MAX-MIN+1)+MIN;

 write(A[i],' ');

 if (A[i]<0) then s1:=s1+A[i];

 if (A[i] mod 3 = 0) then s2:=s2+A[i];

 end;

writeln();

writeln('Сумма всех отрицательных элементов: ',s1);

writeln('Сумма всех элементов, кратных 3: ',s2);

end.

Задача 2:

const N = 20;

const MAX = 33;

const MIN = -15;

var A: array [1..N] of integer;

var i,imax,imin: integer;

begin

randomize();

imin:=1;

imax:=1;

writeln('Исходный массив: ');

for i:=1 to N do

 begin

 A[i]:=random(MAX-MIN+1)+MIN;

 write(A[i],' ');

 if (A[i]<A[imin]) then imin:=i;

 if (A[i]>A[imax]) then imax:=i;

 end;

writeln();

writeln('Номер минимального элемента массива: ',imin);

writeln('Номер максимального элемента массива: ',imax);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

нужно написать программу Вычислить: 10 S=å(xi3+8)0.5 , где xi=xi-1+dx2; x1=2; dx=0.2. i=1
Ваше имя (никнейм)*
Email*
Комментарий*