mado191065
?>

Pascal / всего к оплате считается как сумма начисления + пени. Василий намотал 5 кубов горячей воды . 20 кубов холодной воды и 345.2кв/ч электроэнергии . он решил составить программу в paslac. Требования к программе таковы : пользователь вводит с клавиатуры кол-во дней задержки оплаты, вводит процент пенни с суммы начисления и кол-во кубов и кв/ч электроэнергии

Информатика

Ответы

Viktoriya

я нашол кун.2кв была это

alekseysokolov29816
#include <iostream>
#include <Time.h>
using namespace std;

int main()
{
    int n, i, k;

    cout << "Kolichestvo chisel = ";
    cin >> n;

    srand(time(0));
    int *a = new int[n];

    for (int i = 0; i < n; i++)
    {
        a[i] = rand() % 56 - 10;
        cout << a[i] << " ";
    }
    int min = a[0];

    for (i = 0; i<n; i++)
    if (min>a[i]) {
        min = a[i];
        k = i;
    }

    cout << endl << endl;
    cout << "Min = " << min << endl << "i = " << k << endl;

    system("pause");
    return 0;
}
yanva

готово

Объяснение:

1)

program minimum;

var

 i, n, k: integer;

 min: real;

 A: array of real;

begin

 Write('Введите размер массива: ');

 ReadLn(n);

 SetLength(A, n);

 for i := 0 to n - 1 do

 begin

   Write('Введите A[',i,']=');

   ReadLn(A[i]);

 end;

 min := A[0];

 for i := 1 to n - 1 do

 if A[i] < min then

   begin

     min := A[i];

     k := i;

   end;

 WriteLn('Минимальный элемент - A[',k,'] = ', min);

end.

2)

program summa;

var

 i, t, sum: integer;

 A: array of integer;

begin

 Write('Введите размер массива: ');

 ReadLn(t);

 SetLength(A, t);

 for i := 0 to t - 1 do

 begin

   A[i] := round(random(120) - 60);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 20 then sum := sum + a[i];

 end;

 WriteLn('Сумма чисел, больших 20 = ', sum);

end.

3)

program massiv;

var

 i, k: integer;

 A: array[0..13] of integer;

begin

 for i := 0 to 13 do

 begin

   A[i] := round(random(27) + 3);

   WriteLn('A[', i, '] = ', A[i]);

   if A[i] > 13 then k := k + 1;

 end;

 WriteLn('Количество чисел, больших 13 равно ', k);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal / всего к оплате считается как сумма начисления + пени. Василий намотал 5 кубов горячей воды . 20 кубов холодной воды и 345.2кв/ч электроэнергии . он решил составить программу в paslac. Требования к программе таковы : пользователь вводит с клавиатуры кол-во дней задержки оплаты, вводит процент пенни с суммы начисления и кол-во кубов и кв/ч электроэнергии
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ibombenkova
windless-el
tcmir
tanyatanyat
ANDREY261965
Veselova
uglichwatch
arinaunknown6867
eshabunina
tetralek
Нана_Елена
kosstroy
samogon-mozhaisk
egamedicalbuh
sdvigov