Vladimirovich Aleksandr1889
?>

Отношение Дан массив a1, a2, …an. Необходимо выбрать в нём два элемента ai и aj, такие что iВходные данныеВ первой строке задано целое число 2 ≤n≤ 100 000 — количество элементов в массиве.Во второй строке заданы n целых положительных чисел ai(1 ≤i≤n,  1 ≤ai≤ 5000Выходные данныеВыведите два числа — индексы элементов i и j. Если ответов несколько, то выведите любой из них.Если ответа нет, то выведите два нуля, разделённых пробелом.

Информатика

Ответы

Vip2002www86

а) для представления объектов окружающего мира могут быть использованы: макет застройки жилого района и фотоснимки движения воздушных масс; б) для объяснения известных фактов могут быть использованы: фотоснимки движения воздушных масс, модель полёта самолёта новой конструкции в аэродинамической трубе и схема строения внутренних органов человека; в) для проверки гипотез и получения новых знаний об исследуемых объектах могут быть использованы: фотоснимки движения воздушных масс, модель полёта самолёта новой конструкции в аэродинамической трубе и схема строения внутренних органов человека; г) для прогнозирования могут быть использованы: фотоснимки движения воздушных масс, расписание движения поездов и модель полёта самолёта новой конструкции в аэродинамической трубе; д) для управления могут быть использованы: расписание движения поездов

ERodina1

var

a:integer;

b,c:integer;    

t:integer;

begin

 writeln('Введите двухзначное челое число');

 readln(a);

 if not((a>9)and(a<100)and(a mod 10<> 0))then

   writeln('ERROR');

 if (a>9)and(a<100)and(a mod 10 <> 0)then

 begin

   b := a div 10;

   c := a mod 10;

   t := b-c;

   if t<0 then a:=a+abs(t*10)+t

   else a:= a-t*10+t;

   writeln(a)

 end;  

 end.

Объяснение:

Данная программа написана на Pascal

В программе я также исключил все числа 10,20,30,40,50,60,70,80,90 , так как при смене местами числа будут получаться однозначные(1,2,3,4,5,6,7,8,9)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Отношение Дан массив a1, a2, …an. Необходимо выбрать в нём два элемента ai и aj, такие что iВходные данныеВ первой строке задано целое число 2 ≤n≤ 100 000 — количество элементов в массиве.Во второй строке заданы n целых положительных чисел ai(1 ≤i≤n,  1 ≤ai≤ 5000Выходные данныеВыведите два числа — индексы элементов i и j. Если ответов несколько, то выведите любой из них.Если ответа нет, то выведите два нуля, разделённых пробелом.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gbnn90
marysya60
vasiliiparshin7668
aobuhta4
soa8690
garunkhachatryan
Karpova
marinavg63607
Lesya
Daletskaya Sergei1121
VladimirovichKazakova1202
panstel
Вадим-Рашад323
Styazhkin395