nikziam
?>

Напишите программу, осуществляющую чтение из исходного текстового файла input.txt вход- ных данных (коэффициентов a, b, c), сумму этих коэфициентов ивывод результатов в выходной текстовый файл output.txt. Предполагается, что в input.txt вкаждой строке записаны знаения а, b, c через пробел, а в выходной файл записывается ответ(сумма этих трех перемнныхPascal abc

Информатика

Ответы

tatarinova-51
PascalABC.NETbegin  var a := ReadAllLines('input.txt');  a.Transform(s -> s.ToWords.Sum(x -> x.ToInteger).ToString);  WriteAllLines('output.txt', a);end.

Пример работы:


Напишите программу, осуществляющую чтение из исходного текстового файла input.txt вход- ных данных (
Напишите программу, осуществляющую чтение из исходного текстового файла input.txt вход- ных данных (
Мария1414
Собсна на c++
#include <iostream>
#include <conio.h>
using namespace std;
int main()
{ setlocale(LC_ALL, "Russian");
const int N = 5, M = 5;
int a[N][M];
int min;
cout << "Zapolnite matricu 5 na 5: " << endl;
for (int i(0); i < N; i++)
{ for (int j(0); j < M; j++)
 { cin >> a[i][j]; } }
min = a[0][0];
for (int i(0); i < N; i++)
{ for (int j(0); j < M; j++)
 { if (min > a[i][j])
   min = a[i][j]; } }
cout <<"Minimal`nii element: "<< min << endl;
_getch();
return 0;}
zdanovich90764
#include <iostream>
#include <cmath>
using namespace std;
class Circle
{
private:
    double x;
    double y;
    double r;
public:
    Circle();
    Circle(double xCo, double yCo, double rad);
    double area();
    double centre_dist(Circle & c);
    bool istouch(Circle & c);
};

Circle::Circle()
{
    cout << "Enter x coord: ";
    cin >> x;
    cout << "Enter y coord: ";
    cin >> y;
    cout << "Enter radius: ";
    while (cin >> r && r < 0)
    {
        cout << "Radius can't be negative\n";
        cout << "Enter radius: ";
    }
}

Circle::Circle(double xCo, double yCo, double rad) : x(xCo), y(yCo), r(rad)
{
    if (r < 0)
    {
        cout << "Radius can't be negative\n";
        cout << "Radius set to 0\n";
        r = 0;
    }
}

double Circle::area()
{
    return 3.1415926 * r * r;
}

double Circle::centre_dist(Circle & c)
{
    return sqrt((x - c.x) * (x - c.x) + (y - c.y) * (y - c.y));
}

bool Circle::istouch(Circle & c)
{
    return (this->centre_dist(c) <= r + c.r) ? true : false;
}

int main()
{
    Circle c1;
    Circle c2(0, 0, 5);
    cout << "area of c2: " << c2.area() << endl;
    cout << "centre distance: " << c2.centre_dist(c1) << endl;
    cout << "is touch: ";
    c2.istouch(c1) ? cout << "yes" : cout << "no";
    cout << endl;
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, осуществляющую чтение из исходного текстового файла input.txt вход- ных данных (коэффициентов a, b, c), сумму этих коэфициентов ивывод результатов в выходной текстовый файл output.txt. Предполагается, что в input.txt вкаждой строке записаны знаения а, b, c через пробел, а в выходной файл записывается ответ(сумма этих трех перемнныхPascal abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bmargarita
Васильевичь Виктория457
tat122
Чубкова1290
АлександровнаВладимирович1424
ba5-m
djikia88
Артем Уберт
Olegovna Volkov
Viktorovna_Yurevna
Александровна-Грузман
Сопоставь команды с их назначениями. ​
Gera8061
pavlino-mkr
Vladimirovna1858
maxchuev