kav511
?>

Программиривание в котлин Найти произведение 5⋅6⋅7⋅...⋅13. Найти сумму 1+4+7+11+...+112.

Информатика

Ответы

Юлия1689

Как организовать ожидание в программе до нажатия какой-либо клавиши? В QBasic для этой цели подойдет системная переменная INKEY$. Достаточно присвоить ее значение какой-либо символьной переменной, например А$, и организовать бесконечный цикл до тех пор пока длина значения А$ перестанет отличаться от нуля:

А$=""

М10 : A$=INKEY$ ; IF А$="" THEN GOTO M10

Можно воспользоваться и другим приемом — включить в программу оператор ввода в какую-либо переменную символьного типа. Такая переменная предпочтительнее числовой, т. к. в нее можно ввести пустое значение, нажав только клавишу <Enter>. Кроме того, набор любого отображаемого символа не приведет к ошибке.

В Си временный приостанов до нажатия какой-либо клавиши организуют с функции getch.

В Паскале можно организовать бесконечный цикл, аналогичный приведенному выше варианту для QBasic, с логической функции KeyPressed:

while not KeyPressed;

var

 N: integer;

begin

 write('N = ');

 readln(N);

 writeln;

 writeln('Цифры числа (справа налево):');

 while N > 0 do { <-- Выполняем цикл, пока число больше 0 }

 begin

   write(' ', N mod 10); { <-- выводим остаток деления на 10 }

   N := N div 10 { <== находим целую часть от деления на 10 }

 end;

 readln

end.

Примеры

Входные данные

3

v 3

l 1

u 2

luvu

3

luv

vul

uuu

Выходные данные

6

11 задание не знаю сорри бро дай корону

ortopediya

1)

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   cout << "V = " << x * x * x << endl << "S = " << x * x;

   system("pause");

   return 0;

}

2)

#include <iostream>

using namespace std;

int main() {

   double a, b;

   cin >> a >> b;

   if (a > b) {

       cout << "a > b " << endl << a;

   }

   else {

       cout << "a <= b " << endl << a << b;

   }

   system("pause");

   return 0;

}

3)

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   if (x % 2 == 0) cout << "YES";  

   else cout << "NO";

   cout << endl;

   if (x % 10 == 3) cout << "YES";

   else cout << "NO";

   cout << endl;

   system("pause");

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Программиривание в котлин Найти произведение 5⋅6⋅7⋅...⋅13. Найти сумму 1+4+7+11+...+112.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iraimironova
Korikm
machkura
Nadezhda
amaraks67
ivanjeka87
irinaastapova2011
Vkois56
dmitrievanata83538
vis-lyubov8832
tsatskina857
anastasiaevent4
ksyrika
karpov68
Исакова-Александрович511