patersimon1
?>

Python тема-While Напишите программу, в которой пользователь вводит цены за продукты до тех пор, пока не будет введен ноль. Вывести счет к оплате - сумму за все продукты. Входные данные:Ввод стоимости продуктов на отдельных строках.Выходные данные:Число - стоимость покупки.​

Информатика

Ответы

bagrjashv41

s = 0

x = int(input())

while x != 0:

   s += x

   x = int(input())

print(s)

Объяснение:

Ольга Сергей1822
Математик Эйлер... Швейцария (1707—1727)
Леонард Эйлер родился в 1707 году в семье базельского пастора Пауля Эйлера, друга семьи Бернулли. Рано проявил математические Начальное обучение получил дома под руководством отца, учившегося некогда математике у Якоба Бернулли. Пастор готовил старшего сына к духовной карьере, однако занимался с ним и математикой — как в качестве развлечения, так и для развития логического мышления. Одновременно с обучением в гимназии мальчик увлечённо занимался математикой, а в последние гимназические годы посещал университетские лекции младшего брата Якоба, Иоганна Бернулли.
batalerka391
Математик Эйлер... Швейцария (1707—1727)
Леонард Эйлер родился в 1707 году в семье базельского пастора Пауля Эйлера, друга семьи Бернулли. Рано проявил математические Начальное обучение получил дома под руководством отца, учившегося некогда математике у Якоба Бернулли. Пастор готовил старшего сына к духовной карьере, однако занимался с ним и математикой — как в качестве развлечения, так и для развития логического мышления. Одновременно с обучением в гимназии мальчик увлечённо занимался математикой, а в последние гимназические годы посещал университетские лекции младшего брата Якоба, Иоганна Бернулли.

Базельский университет в XVII—XVIII веках
20 октября 1720 года 13-летний Леонард Эйлер стал студентом факультета искусств Базельского университета. Но любовь к математике направила Леонарда по иному пути. Вскоре мальчик обратил на себя внимание профессора Иоганна Бернулли. Он передал одарённому студенту математические статьи для изучения, а по субботам пригласил приходить к нему домой, чтобы совместно разбирать непонятное. В доме своего учителя Эйлер познакомился и подружился с сыновьями Бернулли — Даниилом и Николаем, также увлечённо занимавшимися математикой.
8 июня 1724 года 17-летний Леонард Эйлер произнёс на латыни речь о сравнении философских воззрений Декарта и Ньютона и был удостоен учёной степени магистра.
В последующие два года юный Эйлер написал несколько научных работ. Одна из них, «Диссертация по физике о звуке» , получившая благоприятный отзыв, была представлена на конкурс для замещения неожиданно освободившейся в Базельском университете должности профессора физики (1725). Но, несмотря на положительный отзыв, 19-летнего Эйлера сочли слишком юным, чтобы включить в число кандидатов на профессорскую кафедру. Надо отметить, что число научных вакансий в Швейцарии было совсем невелико. Поэтому братья Даниил и Николай Бернулли уехали в Россию, где как раз шла организация Академии наук; они обещали похлопотать там и о должности для Эйлера.
В начале зимы 1726 года Эйлеру сообщили из Санкт-Петербурга: по рекомендации братьев Бернулли он приглашён на должность адъюнкта по физиологии с окладом 200 рублей [3]. Получение аванса для компенсации проездных расходов растянулось почти на год, и лишь 5 апреля 1727 года Эйлер навсегда покинул Швейцарию.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python тема-While Напишите программу, в которой пользователь вводит цены за продукты до тех пор, пока не будет введен ноль. Вывести счет к оплате - сумму за все продукты. Входные данные:Ввод стоимости продуктов на отдельных строках.Выходные данные:Число - стоимость покупки.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annazhurawlewa
Vladimir1172
tboychenko
purchase
maisa1991
juliaipatova1739
alenih13
dmitzu8594
Kochetova92
mariapronina720126
Николаев
Татьяна
Ivanovich_Kostik898
zu87zu87
Васильевна Владимирович
▲