farmprofi
?>

Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на python, используя вложенные циклы Вложенные циклы. Все звездочки (*) должны печататься одной функцией print(”*”, end=“”

Информатика

Ответы

mary---jane49

def printGraph(size):

 for numI in range(size):

   row = ''

   for numJ in range(size - numI):

     row += '*'

   if row:

     print(row)

 for numI in range(size + 1):

   if numI == 1:

     continue;

   row = ''

   for numJ in range(numI):

     row += '*'

   if row:

     print(row)

 

print(printGraph(5))

Объяснение:


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
Plotnikovangav

n = int(input("Введите размер >>> "))

for i in range(n, 0, -1):

   print("*"*i)

for i in range(2, n + 1, 1):

   print("*"*i)

============

Не забывайте нажать " ", поставить оценку и, если ответ удовлетворил, то выберите его как "Лучший"

Бодрого настроения и добра!

Успехов в учебе!


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
Allahverdi_Мария475
1000 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*0 = 8 + 0 + 0 + 0 = 8
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0110 = 2^3*0 + 2^2*1 + 2^1*1 + 2^0*0 = 0 + 4 + 2 + 0 = 6
0001 = 2^3*0 + 2^2*0 + 2^1*0 + 2^0*1 = 0 + 0 + 0 + 1 = 1
0101 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*1 = 0 + 4 + 0 + 1 = 5
0100 = 2^3*0 + 2^2*1 + 2^1*0 + 2^0*0 = 0 + 4 + 0 + 0 = 4
1001 = 2^3*1 + 2^2*0 + 2^1*0 + 2^0*1 = 8 + 0 + 0 + 1 = 9

Если это одно большое число, то вот так

1000000101100001010101001001 = 2^27*1 + 2^26*0 + 2^25*0 + 2^24*0 + 2^23*0 + 2^22*0 + 2^21*0 + 2^20*1 + 2^19*0 + 2^18*1 + 2^17*1 + 2^16*0 + 2^15*0 + 2^14*0 + 2^13*0 + 2^12*1 + 2^11*0 + 2^10*1 + 2^9*0 + 2^8*1 + 2^7*0 + 2^6*1 + 2^5*0 + 2^4*0 + 2^3*1 + 2^2*0 + 2^1*0 + 20*1 = 134217728 + 0 + 0 + 0 + 0 + 0 + 0 + 1048576 + 0 + 262144 + 131072 + 0 + 0 + 0 + 0 + 4096 + 0 + 1024 + 0 + 256 + 0 + 64 + 0 + 0 + 8 + 0 + 0 + 1 = 135664969

^ - Возведение в степень
terehin863
Оперативная память - это память кратко то есть она не сохраняется на компьютере. Основная задача оперативной памяти - это давать программам временную память для их потребностей. Вот, например, есть у тебя приложение А и приложение В. Ты делаешь что-то в приложение А и внезапно приходит сообщение в приложении Б. Ты ведь не станешь закрывать приложение А? Потому что можешь его скрыть. Когда ты скрываешь приложение ему выделяется оперативная память, которая позволяет свернуть приложение, а не закрывать его. И когда ты ответишь на сообщение в программе Б, ты спокойно можешь вернуться обратно к работе в приложении А. Это существенно ускоряет работу людей за компьютером.

Долговременная память - это память, которая будет вечно на компьютере. Единственный от неё избавится это собственноручно удалить.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на python, используя вложенные циклы Вложенные циклы. Все звездочки (*) должны печататься одной функцией print(”*”, end=“”
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vbg238
alexeytikhonov
Сурат1199
krasnova1977
annakuzina2023
Aleks120498
Филипп1054
Рафаэль633
Yevgenii_Gurtovaya1532
hristos1212
cherry-sweet871435
Rinatum1978
gutauta6
chechina6646
▲