nunabat457
?>

написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскаль, но нужен JS. Задание 1. Напишите программу на языке Pascal для вывода на экран следующей информации: 1 строка  Ваша фамилия имя отчество, 2 строка  номер группы, наименование факультета и института. 2. Даны два действительных положительных числа. Найти среднее арифметическое и среднее геометрическое этих чисел очень заранее

Информатика

Ответы

Олег86

В браузере консольный ввод организовать нереально.

В качестве среды исполнения использовал Node.js версии 12.18.3.

Иллюстрации кода, а также пример вывода добавлены во вложения.

=========================

Ваши оценки и отзывы лучше оценить качество ответа.

Если ответ удовлетворил, не забудь отметить его как "Лучший".

=========================

Код:

"use strict";

const readline = require('readline');

// IO realisation

(async function QNAThread(dialog) {

   const qna = readline.createInterface({

       input: process.stdin,

       output: process.stdout

   });

   await dialog(function askMe(text) {

       return new Promise((resolve, reject) => {

           qna.question(text + " ", resolve);

       });

   });

   qna.close();

})(mainDialog);

function firstTask() {

   console.log("[Your name and lastname here]");

   console.log("[Information about your group and university]");

}

function secondTask(a, b) {

   return [(a+b)/2, Math.sqrt(a*b)];

}

function thirdTask(x) {

   return Math.pow(Math.cos(Math.PI * x), 2) * Math.log(3*x);

}

function fifthTask(x) {

   return (x*x*x - 5*x*x + 1) !== 10;

}

function sixth(x, b) {

   return (x*x*x + 4*x > -1) && b;

}

// Here is the main script!

async function mainDialog(askMe) {

   //Task #1

   console.log("{First task}");

   firstTask();

   //Task #2

   console.log("\n{Second task}");

   console.log(`Answers for [A=4] and [B=7] are ${secondTask(4, 7)}\n`);

   //Task #3

   console.log("{Third task}");

   let x = Number.parseFloat(await askMe("VVEDITE ZNACHENIE X:=\n"));

   console.log(`PRI X=\t${x} znachenie Y=\t${thirdTask(x)}\n`);

   //Task #4

   console.log("{Fourth task}");

   console.log(`1) При x=${x} значение функции y=\t${thirdTask(x)};`);

   const inner = `2) При x=${x}`;

   console.log(`${inner}\n${" ".repeat(inner.length)}\tзначение функции y=\t${thirdTask(x)};`);

   console.log("*".repeat(40));

   console.log(`3) При x=${x} \n\nзначение функции y=\t${thirdTask(x)};`);

   console.log("*".repeat(40));

   //Task #5

   console.log("\n{Fifth task}");

   x = Number.parseFloat(await askMe("Enter the X value:"));

   console.log(`For x=${x} logical value of goal expression is \"${fifthTask(x)}\".`);

   //Task #6

   console.log("\n{Sixth task}");

   x = 2;

   const b = true;

   console.log(`For [x=${x}] and [b=${b}] logical value of goal expression is ${sixth(x, b)}.`)

}


написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскал
написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскал
написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскал
написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскал
doorhan42n6868
Program Trapez;      {название программы}    
 uses Crt;               {подключаемый модуль}

 var a, b, alfa: real;   {переменные: стороны и угол при основании трапеции}
     h, S: real;           {переменные: высота и площадь}

begin                       {начало}
 ClrScr;                    {очистка экрана}
 repeat                     {цикл ввода}
   Write (' alfa (w grad) = ');      {ввод угла}
   ReadLn(alfa);
   Write (' a = ');    ReadLn(a);  {ввод большей стороны}
   Write (' b = ');    ReadLn(b);  {ввод меньшей стороны}
 until (a>b) and (alfa<>90) ;      {контроль за вводом: надо а>b и alfa<>90}
 alfa:=alfa*pi/180;                    {перевод в радианы}
 h:=(a-b)/2*sin(alfa)/cos(alfa);    {вычисление высоты}
 S:=(a+b)*h/2;                          {вычисление площади}
 WriteLn(' S = ', S:6:2);            {вывод результата}
 ReadLn;                                {ожидание нажатия ENTER}
end.                                       {конец}
mbobo28311
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать код на JavaScript для следующих заданий, второй вариант, с 1 по 6 задание. В условии паскаль, но нужен JS. Задание 1. Напишите программу на языке Pascal для вывода на экран следующей информации: 1 строка  Ваша фамилия имя отчество, 2 строка  номер группы, наименование факультета и института. 2. Даны два действительных положительных числа. Найти среднее арифметическое и среднее геометрическое этих чисел очень заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Виктор-Богданов
Sergei-Gradus199
mila-vsv
nsmmkrtchyan
egcuzn86
АлександрАлина
lolydragon
Powerbasses5521
Игоревна
dilanarthur27
Volodka
ЕкатеринаРустам
Наталья_Васищев
natasham-716
uisfbu7777733