1)звуковой процессор, цифро-аналоговый преобразователь (цап), усилитель. 2)аналоговый звук представляет собой плавную кривую (синусоиду) . в компьютере присутствует только цифровой сигнал, который не может быть плавной кривой. поэтому кривая преобразуется в линию ступенями. а 32-х разрядность говорит о том, что сигнал определённой длины разбивается на 32 части. получается тридцать две мелкие ступени. а если будет 16 бит, то будет 16 ступеней в 2 раза больших в размере. 3)это стандарт цифровой звукозаписи, формат обмена данными между электронными музыкальными инструментами.
Klicheva_Ermachenkova1536
10.03.2020
Байт (англ. byte) (русское обозначение: байт и Б; международное: B, byte)[1] — единица хранения и обработки цифровой информации; совокупность битов, обрабатываемая компьютером одновременно. В современных вычислительных системах байт состоит из 8 бит и, соответственно, может принимать одно из 256 (от 0 до 255) различных значений (состояний, кодов). Однако в истории компьютерной техники существовали решения с иными размерами байта (например, 6, 32 или 36 бит), поэтому иногда в компьютерных стандартах и официальных документах для однозначного обозначения группы из 8 бит используется термин «октет» (лат. octet). В большинстве вычислительных архитектур байт — это минимальный независимо адресуемый набор данных.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу с оператором case , которая определяет день недели(пн(1..вс(7)), всего дней 366
#include <iostream>
using namespace std;
void findDayOfWeek(int day) {
switch (day) {
case 1:
cout << "Понедельник";
break;
case 2:
cout << "Вторник";
break;
case 3:
cout << "Среда";
break;
case 4:
cout << "Четверг";
break;
case 5:
cout << "Пятница";
break;
case 6:
cout << "Суббота";
break;
case 7:
cout << "Воскресенье";
break;
default:
findDayOfWeek(day - 7);
}
}
int main() {
setlocale(0, "RU");
int day;
cin >> day;
findDayOfWeek(day);
return 0;
}