treneva359
?>

Напишите программу, которая выводит на консоль простые числа в промежутке от [2, 100]. Используйте для решения этой задачи оператор “%” (остаток от деления) и циклы. Используйте циклы с метками. ​

Информатика

Ответы

Евгений

program z1;

var a: array [1..15] of real;

i, k, b: integer;

proizv: real;

begin

proizv:= 1;

a[1]:= 0.01;

a[2]:= -3;

a[3]:= 0;

a[4]:= 1.25;

a[5]:= -371;

a[6]:= 0.5;

a[7]:= -0.1;

a[8]:= 1.2;

a[9]:= -5;

a[10]:= -172.3;

a[11]:= 19783;

a[12]:= -2.7;

a[13]:= 43.51;

a[14]:= 0;

a[15]:= -0.02;

b:= -3;

k:= 0;

for i:=1 to 15 do

begin

if (a[i] <> 0) and (a[i] > b) then

begin

proizv:= proizv * a[i];

k:= k+1;

end;

end;

writeln('Количество чисел, подходящих условию: ', k);

writeln('Произведение чисел, подходящих условию: ', proizv);

end.

Объяснение:

На фото нарисована блок-схема, она немного криво сфоткана, надеюсь разберёшься. Если есть вопросы - задавай :)


с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
с информатикой надо. Составить блок-схему алгоритма и программу на Паскале для обработки массива из
Овчинников_Грузман

1. Для чего служит дисковод?

в) Для записи информации в память  

2. Файл, подготовленный с текстового процессора, называется

б) Текст

3. Для чего нужна дискета?

г) все ответы верны

4. Какова задача принтера?

г) Распечатка информации на бумагу

5. Задача клавиши Delete:

а) Удаление текста и символа справа от курсора

6. В меню текстового редактора не входит:

в) Рисунок

7. Для чего служит клавиша Shift?

а) Для ввода заглавных букв

8. В текстовом редакторе невозможно:

б) Рисовать  

9. Укажите название текстового редактора

г) Верны ответы а и в

10. Как переместить окно?  

в) Навести мышь на строку заголовка окна и перетащить

11. Как переместить окно?

в) Навести мышь на строку заголовка окна и перетащить

12. Любая информация, сохранённая под каким-либо именем во внешней памяти, называется

г) Файл

13. Пиктограмма Ярлыка отличается от пиктограмм настоящих файлов тем, что:

в) На его значке есть стрелочка

14. Ученик должен сидеть от компьютера на расстоянии:

а) не меньше, чем 50 – 60см;  

15. Устройство для вывода информации из компьютера на бумагу?

в) Принтер

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выводит на консоль простые числа в промежутке от [2, 100]. Используйте для решения этой задачи оператор “%” (остаток от деления) и циклы. Используйте циклы с метками. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

asvavdeeva
ipeshindina236
Stroeva19651938
ekater01806
rinat
Екатерина
Шеина
ЕвгенияСергеевна
dimon198808744
Александр
darialyagina
saltikovaK.S.1482
aifbon
Nazart44446
mihalewanadia20176987