Элизбарян
?>

Решить на языке питон 3. Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали S журавликов. Сколько журавликов сделал каждый ребенок, если известно, что Петя и Сережа сделали одинаковое количество журавликов, а Катя сделала в два раза больше журавликов, чем Петя и Сережа вместе? Формат ввода Записано одно натуральное число S – общее количество сделанных журавликов ( S < 10 в 6 степени ) . Формат вывода Вывести три числа, разделенных пробелами – количество журавликов, которые сделал каждый ребенок (Петя, Катя и Сережа

Информатика

Ответы

koptevan6

(я так понял масив(матрица) "состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29" вводитса з клавиатуры) (я на Паскале на ошибки не проверял)

program dl9_aridrettnir;

var a:array [1..10,1..5] of inteher;

sum:array [1..10] of integer;

i,q,j:integer; 

begin

writeln ('Vvedit masiv ot 0 do 29');

for i:=1 to 10 do

begin

for q:=1 to 5 do begin

readln (a[i,q]);

end; end;

for i:=1 to 10 do

begin sum[i]:=0;

for q:=1 to 5 do begin

for j:=1 to 10 do begin 

sum[i]:=a[q,j]+sum[i];

end; end;end;

readln

end. 

 

Юлия1972
Алгоритм может быть, например, таким. Если нужно вывести нулевое число Фибоначчи, выведем 1, иначе будем считать. Сохраним в переменную номер текущего числа Фибоначчи (изначально 1) и значения текущего и предыдущего элементов (в начале 1 и 1), затем в цикле будем пересчитывать значения элементов, увеличивая номер текущего элемента. Когда номер элемента совпадёт с нужным, выведем ответ.

Реализация (python 3):
n = int(input())
if n == 0:
    print(1)
else:
    prev, curr = 1, 1
    i = 1
    while i < n:
        curr, prev = prev + curr, curr
        i += 1
    print(curr)

Запустив программу, можно узнать, что f10 = 89, f25 = 121393, а f40 = 165580141

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на языке питон 3. Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали S журавликов. Сколько журавликов сделал каждый ребенок, если известно, что Петя и Сережа сделали одинаковое количество журавликов, а Катя сделала в два раза больше журавликов, чем Петя и Сережа вместе? Формат ввода Записано одно натуральное число S – общее количество сделанных журавликов ( S < 10 в 6 степени ) . Формат вывода Вывести три числа, разделенных пробелами – количество журавликов, которые сделал каждый ребенок (Петя, Катя и Сережа
Ваше имя (никнейм)*
Email*
Комментарий*