katrinasvr
?>

для целочисленного массива X(n), заданного датчиком случайных чисел в интервале [-15;25], найти наибольший из отрицательных элементов Язык Паскаль Информатика 11 класс

Информатика

Ответы

femida69

pascal

Объяснение:

program maximum;

var n, i, max: integer;

   x: array of integer;

begin

   Write('Введите размер массива:');

   ReadLn(n);

   SetLength(x,n);

   Randomize();

   max := -15;

   WriteLn('Массив:');

   for i := 0 to n - 1 do

   begin

     x[i] := round(random(41) - 15);

     Write(x[i],', ');

     if (x[i] > max) and (x[i] < 0) then max := x[i];

   end;

   WriteLn();

   WriteLn('Наибольший из отрицательных элементов равен ', max);

end.

astahova

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
Ekaterina1654

1.

program z1;

var a:array [1..10] of integer;

i,k:integer;

begin

write ('Введите элементы массива через пробел и нажмите Enter ');

for i:=1 to 10 do read (a[i]);

write ('Массив: ');

for i:=1 to 10 do write (a[i],'  ');

writeln;

write ('Номера элементов больше 5: ');

for i:=1 to 10 do if a[i] > 5 then

begin

write (i,'  ');

k:=k+1

end;

writeln;

writeln ('Элементов больше 5: ',k)

end.

2.

program z2;

var s:string;

begin

readln (s);

while pos('о',s)<>0 do delete(s,pos('о',s),1);

writeln(s)

end.

Объяснение:

Смотри картинки

2. Программа удаляет только строчные русские о


НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач
НУЖНА ЗАДАЧА: Составить программу на Паскале для обработки одномерного массива из 10 элементов. Знач

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

для целочисленного массива X(n), заданного датчиком случайных чисел в интервале [-15;25], найти наибольший из отрицательных элементов Язык Паскаль Информатика 11 класс
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aananasAnastiya1270
marketing
alazaref
Sergeevna803
drevile57
cleopatra1959
dailyan539
Igor120
Zhamynchiev
makitra08
punchf
igor-790
Лоскутова
Vip2002www86
megaromeo
▲