Novikova
?>

Даны 3 числа x, y, z. Если числа даны по возрастанию, то удвоить каждое из них, иначе извлечь модуль. Написать программу в паскале и блок - схему

Информатика

Ответы

Vladimirovich58

program xyz;

uses

crt;

var

x, y, z: real;

begin

writeln('Введите числа x, y, z:');

readln(x, y, z);

if (x < y) and (y < z) then

begin

x := x * 2;

y := y * 2;

z := z * 2;

end

else

begin

x := abs(x);

y := abs(y);

z := abs(z) ;

end;

writeln('x= ',x, ';') ;

writeln('y= ',y, ';') ;

writeln('z= ',z, ';') ;

end.


Даны 3 числа x, y, z. Если числа даны по возрастанию, то удвоить каждое из них, иначе извлечь модуль
Дмитриевич Бирковская69
//Я просто опишу метод записи матрицы
const n=100;
var ar:array of array of integer;
 ars:array of array of string;
 i:integer;
 
procedure complection(var ar:array of array of integer;var ars:array of array of string);
var
 i,j:integer;
begin;
for i:=1 to n do
 begin;
   for j:=1 to n do
    begin;
     ar[i,j]:=random(9);
     str(ar[i,j],ars[i,j]);
    end;
 end;
end;

procedure burning(ars:array of array of string);
var
 i,j:integer;
 t:text;
 begin;
  assign(t,'text.txt');
  rewrite(t);
  for i:=1 to n do
   begin;
    writeln(t,' ');
     for j:=1 to n do
      write(t,ars[i,j],' ');
   end;
 end;  

begin;
randomize;
setlength(ar,n+1);
setlength(ars,n+1);
for i:=1 to n do
 begin;
  setlength(ar[i],n+1);
  setlength(ars[i],n+1);
 end;
complection(ar,ars);
burning(ars);
end.
delonghisochi
1)var ar:array of integer;
max,min,s,i,n,maxi,mini:integer;
begin;
randomize;
max:=-1;
min:=101;
readln(n);
setlength(ar,n+1);
writeln('Array:');
for i:=1 to n do
 begin;
  ar[i]:=random(100);
  write(ar[i]:4);
  if max<ar[i] then
   begin;
    max:=ar[i];
    maxi:=i;
   end;
  if min>ar[i] then
   begin;
    min:=ar[i];
    mini:=i;
   end;
  s:=s+ar[i];
 end;
ar[maxi]:=s;
ar[mini]:=s;
writeln;
writeln('Final array:');
for i:=1 to n do
write(ar[i]:4);
end.
2)var ar:array of integer;
k,h,i,s:integer;
f:real;
begin;
randomize;
readln(h);
setlength(ar,h+1);
writeln('Array:');
for i:=1 to h do
 begin;
  ar[i]:=random(100)-50;
  write(ar[i]:4);
  if (ar[i]>0) and (ar[i] mod 2=0) then
   begin;
    inc(k);
    s:=s+ar[i];
   end;
 end;
f:=s/k;
writeln;
writeln('Result:',f);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны 3 числа x, y, z. Если числа даны по возрастанию, то удвоить каждое из них, иначе извлечь модуль. Написать программу в паскале и блок - схему
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lena260980
Виталий
annanudehead1426
Igor1406
Yelena Kotova
metrikajulia
evavard
elenaperemena8
zimbickij19
zelreiki
Сергеевна_Юрикович
Strelkov-Roman1263
РоманТрофимов2012
Vasilii1891
taa19707470