vladai2
?>

Написать программу на питон Как известно, дети часто не любят делиться игрушками. Особенно сложно дела с игрушками обстоят одной в семье, в которой n детей. Пока игрушки равномерно были разложены на полу, каждый ребенок начертил мелом на полу прямоугольник со сторонами, параллельными стенам комнаты, и объявил, что он будет играть в игрушки, лежащие в его прямоугольнике. Поскольку за честностью деления никто не следил, то получившиеся прямоугольники были разных размеров, пересекались и накладывались друг на друга. Поэтому в какой-то момент детям стало интересно, в какой области комнаты они могут играть все вместе одновременно. Входные данные В первой строке ввода задано число n — количество детей, и, соответственно, прямоугольных областей на полу (1⩽n⩽2⋅105 В каждой из следующих n строк дана информация о соответствующем прямоугольнике — четверка чисел x1, y1, x2, y2, первые два из которых задают координаты левого нижнего угла, а вторые — правого верхнего, если смотреть на комнату сверху (−109⩽x1

Информатика

Ответы

pnat1235
USES CRT,Graph;VAR Device,Mode:Integer;    i,x,y,s:Integer;BEGINCLRSCR;       Device:=0;       InitGraph(Device,Mode,'');       s:=100;       x:=320;       y:=240;       for i:=1 to 9 do           begin               SetLineStyle(0,0,ThickWidth);               Circle(x,y,s);               Delay(200);               SetColor(Black);               Circle(x,y,s);               s:=s-10;               SetColor(White);           end;            for i:=1 to 9 do           begin               SetLineStyle(0,0,ThickWidth);               Circle(x,y,s);               Delay(200);               SetColor(Black);               Circle(x,y,s);               s:=s+10;               SetColor(White);           end;          Circle(x,y,s);Readln;END.
lele52
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
function AutoMorph(n:integer):boolean;
begin
  var s1:=n.ToString;
  Result:=(s1=(n*n).ToString.Right(s1.Length))
end;

begin
  var a,b:integer;
  Write('Введите а и b: '); Read(a,b);
  for var i:=a to b do
    if AutoMorph(i) then Print(i)
end.

Тестовое решение:
Введите а и b: 1 10000
1 5 6 25 76 376 625 9376

Попробовал переписать функцию в более примитивный вид. По-моему, она не стала проще, только удлинилась...

function AutoMorph(n:integer):boolean;
begin
  var s1:=IntToStr(n); // n переводим в строковое представление
  var s2:=IntToStr(n*n); // n*n переводим в строковое представление
  var l1:=Length(s1); // длина строки s1
  s2:=RightStr(s2,l1); // правые l1 символов из s2
  Result:=(s1=s2)
end;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на питон Как известно, дети часто не любят делиться игрушками. Особенно сложно дела с игрушками обстоят одной в семье, в которой n детей. Пока игрушки равномерно были разложены на полу, каждый ребенок начертил мелом на полу прямоугольник со сторонами, параллельными стенам комнаты, и объявил, что он будет играть в игрушки, лежащие в его прямоугольнике. Поскольку за честностью деления никто не следил, то получившиеся прямоугольники были разных размеров, пересекались и накладывались друг на друга. Поэтому в какой-то момент детям стало интересно, в какой области комнаты они могут играть все вместе одновременно. Входные данные В первой строке ввода задано число n — количество детей, и, соответственно, прямоугольных областей на полу (1⩽n⩽2⋅105 В каждой из следующих n строк дана информация о соответствующем прямоугольнике — четверка чисел x1, y1, x2, y2, первые два из которых задают координаты левого нижнего угла, а вторые — правого верхнего, если смотреть на комнату сверху (−109⩽x1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

russstep
Городничий_Коновалова384
Negutsa_Kseniya524
volkovaoksana19806037
Puschdom
aivia29
grazia2017
Kuznetsova702
gorbelena1971
hbqhzwtd
Lapushkin1988
Nadirovich1317
FATAHOVAMAINA
andre6807
▲