Екатерина_Кирушев
?>

Напишите программу, которая будет читать строку, а затем выводить четвертый символ этой строки на экран паскале .

Информатика

Ответы

Kuznetsova702

// PascalABC.Net v.3.2, сборка 1325 (19.10.2016)

Var s:string;i:longint;

Begin

readln(s);

readln(i);

writeln(s[i]);

End.

Объяснение:

s - строка

i - целое число

Формат вывода: s[i] - i-тый символ строки s

Пример ввода: string

2

Пример вывода: t

yurick2071488
Самые первые современные компьютеры - к числу которых относится Марк-1 - были основаны на электромеханических переключателях, которые широко применялись тогда в технике телефонной связи. Когда переключатель открыт (слева), ток в цепи отсутствует. Но если на обмотку железного сердечника (справа) подать ток низкого напряжения (красный), то в сердечнике создается магнитное поле, притягивающее один конец вращающегося на шарнире рычажка; другой его конец в этот момент сжимает контакты: цепь замыкается и по ней начинает проходить электрический ток (зеленый). Разработка машины Марк-1 проходила на удивление гладко. Успешно пройдя первые испытания в начале 1943 г., она была затем перенесена в Гарвардский университет, где стала яблоком раздора между ее изобретателем и его шефом.

Следует заметить, что и Эйкен, и Уотсон, обладая немалым упрямством, любили делать все по-своему. Сначала они разошлись во мнениях относительно внешнего вида машины.Марк-1, достигавший в длину почти 17 м и в соту более 2,5 м, содержал около 750 тыс. деталей, соединенных проводами общей протяженностью около 800 км. Для инженера такая махина была поистине кошмарным сном. Эйкен хотел оставить внутренности машины открытыми, чтобы специалисты имели возможность видеть ее устройство. Уотсон же, которого, как всегда, больше беспокоила репутация фирмы IBM, настаивал, чтобы машину заключили в корпус из стекла и блестящей нержавеющей стали.

Уотсон вышел победителем в спорах по этому и другим вопросам, но, когда Марк-1 был «представлен» прессе в августе 1944 г., Эйкен взял реванш. Он вскользь упомянул о роли, которую сыграла в этом проекте корпорация IBM, а лично о Томасе Уотсоне вообще не сказал ни слова. Уотсон был в бешенстве. «Вы не смеете так пренебрежительно относиться к IBM! - кричал он Эйкену. - Для меня IBM значит не меньше, чем для вас, выпускников Гарварда, ваш университет!» Сын и преемник Уотсона Том Уотсон-младший говорил позже: «Имей Эйкен и отец под рукой пистолеты, они бы убили друг друга». 
ldfenix87
Program SandP; //Название программы var //Описание переменных x,y: real; // Стороны прямоугольника S: real; // Площадь прямоугольника P: real; // Периметр прямоугольника procedure RectSP(a,b: real; var S,P:real); //Процедура begin S := a * b; //Нахождение площади P := a + b; //Нахождение суммы end; begin //Начало основной части программы writeln('Введите стороны прямоугольника: '); //Диалог с пользователем readln(x,y); //Считывание сторон RectSP(x,y,S,P); //Вызов процедуры writeln('Площадь равна ',S); //Вывод площади writeln('Периметр равен ',P); //Вывод периметра end. //Конец программы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая будет читать строку, а затем выводить четвертый символ этой строки на экран паскале .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Alekseevich1012
Dmitrychekov9
Pavlushina-Novikova
elegiy
Ушакова1902
alicia179
Нина1449
Aleksandr768
citioil15
Дмитрий-Олейникова
lbondareva
alexeylipatov
kiruha0378
Анатольевич1707
starabanov