Кристина910
?>

Составить программу для расчета двух значений z1 и z2, результаты которых должны совпадать. Ввод исходных данных можно задавать при декларации или вводить с клавиатуры. Игнорировать возможность деления на 0 (5 ПРИМЕР)

Информатика

Ответы

vasenkova1981
Блок схема по сказке "Каша из топора"
начало ( овал)
     ↓
наколоть дрова (прямоугольник)
      ↓
принести воду (прямоугольник)
       ↓
развести костёр (прямоугольник)
      ↓
взять горшок (прямоугольник)
      ↓
поставить горшок на огонь (прямоугольник)       
↓
налить воду в горшок  (прямоугольник)
        ↓
взять топор (прямоугольник)
         ↓
положить топор в горшок  (прямоугольник)          
↓
добавить гречку  (прямоугольник)           
↓
положить масло, соль (прямоугольник)            
↓
изъять топор из горшка (прямоугольник)
             ↓
взять тарелку (прямоугольник)
              ↓
взять ложку (прямоугольник)
               ↓
положить ложкой кашу в тарелку (прямоугольник)               
↓
конец (овал)
dvbbdv4
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var s:=ReadlnString;
  s:=s.RegexReplace('ма','');
  Writeln('Длина=',s.Length,': ',s)
end.

Пример
Ведьма измазала маслом карман гнома
Длина=25: Ведь иззала слом карн гно

№2

begin
  var s:=ReadlnString;
  Writeln('Количество букв "с" равно ',s.Where(t->t='с').Count)
end.

Пример
Ассистент профессора сидел за столом и что-то писал
Количество букв "с" равно 8

№3

begin
  var s:=ReadlnString;
  var d:=s.Where(t->t='е').Count-s.Where(t->t='о').Count;
  if d>0 then Writeln('Буква "е" встречается чаще буквы "о"')
  else
   if d<0 then Writeln('Буква "о" встречается чаще буквы "е"')
   else Writeln('Буквы "е" и "о" встречаются динаковое число раз')
end.

Пример
Мороз и солнце; день чудесный! Еще ты дремлешь, друг прелестный.
Буква "е" встречается чаще буквы "о"

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для расчета двух значений z1 и z2, результаты которых должны совпадать. Ввод исходных данных можно задавать при декларации или вводить с клавиатуры. Игнорировать возможность деления на 0 (5 ПРИМЕР)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nikomuneskazhu60
gulsinatahckeeva
sahar81305
Кирилл_Гульницкий
Буду блогодарна уровень 6 класса
Voronina747
mail5
bb495
studiojanara
oloinics
VladimirovnaBugrova
mariy-inkina8
veronikagrabovskaya
zsa100
balabinatanya7174
Горина
▲