slipu817838
?>

Написать программу или хотя бы что нужно делать.Вникнуть никак не могу На Солнечном острове живут w белых и b чёрных хамелеонов. Хамелеоны – это животные, менять свой цвет. При встрече оба хамелеона меняют свой цвет на противоположный. Например, при встрече двух белых (или чёрных) хамелеонов оба становятся чёрными (белыми), а при встрече хамелеонов белого и чёрного цвета они превращаются в хамелеонов чёрного и белого цвета. В остальных случаях ничего не происходит. Вам необходимо определить, смогут ли все хамелеоны окраситься в один цвет

Информатика

Ответы

slastena69678

Создаёшь массив, заполняешь его, считаешь сумму и произведение, и обрабатываешь условие:


#include <stdio.h>

#include <stdlib.h>

#include <time.h>

#include <conio.h>

#define RANDOM_MIN -9

#define RANDOM_MAX 9

int main(void) {

srand(time(NULL)); /* for "visible" random */

 

int N;

scanf("%d", &N);

 

int *A = malloc(sizeof(int) * N);

int sum = 0;

int prd = 1;

 

printf("elements: ");

 

int i;

for (i = 0; i < N; i++) {

 A[i] = RANDOM_MIN + rand() % (RANDOM_MAX + abs(RANDOM_MIN) + 1);

 

 printf("%d ", A[i]);

 

 if (A[i] > 0) {

  sum += A[i];  

 } else if (A[i] < 0) {

  prd *= A[i];

 }

}

 

printf("\n");

printf("summa: %d\n", sum);

printf("product: %d\n", prd);

 

if (sum > prd) {

 int max = A[0];

 

 for (i = (0 + 1); i < N; i++) {

  if (max < A[i]) {

   max = A[i];

  }

 }

 

 printf("max element is: %d", max);

} else {

 printf("product higher than summa");

}

 

getch();

free (A);

return 0;

}

Natakarpova75732

на 2 pin подключаем кнопку

на 3, 4, 5 pin подключаем светодиоды


а вот скетч


#include <Arduino.h>

#include <Wire.h>

#include <SoftwareSerial.h>

double angle_rad = PI/180.0;

double angle_deg = 180.0/PI;

double x;

void setup(){

   pinMode(2,INPUT);

   pinMode(3,OUTPUT);

   pinMode(4,OUTPUT);

   pinMode(5,OUTPUT);

}

void loop(){

   if(!((x) > (3))){

       if(((digitalRead(2))==(true))){

           x += 1;

           while(!(((digitalRead(2))==(false

           {

               _loop();

           }

       }

   }else{

       x = 0;

   }

   if((x) > (0)){

       digitalWrite(3,1);

   }else{

       digitalWrite(3,0);

   }

   if((x) > (1)){

       digitalWrite(4,1);

   }else{

       digitalWrite(4,0);

   }

   if((x) > (1)){

       digitalWrite(5,1);

   }else{

       digitalWrite(5,0);

   }

   _loop();

}

void _delay(float seconds){

   long endTime = millis() + seconds * 1000;

   while(millis() < endTime)_loop();

}

void _loop(){

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу или хотя бы что нужно делать.Вникнуть никак не могу На Солнечном острове живут w белых и b чёрных хамелеонов. Хамелеоны – это животные, менять свой цвет. При встрече оба хамелеона меняют свой цвет на противоположный. Например, при встрече двух белых (или чёрных) хамелеонов оба становятся чёрными (белыми), а при встрече хамелеонов белого и чёрного цвета они превращаются в хамелеонов чёрного и белого цвета. В остальных случаях ничего не происходит. Вам необходимо определить, смогут ли все хамелеоны окраситься в один цвет
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Васенкова204
Aleksandrovich1075
murza2007
tretyakovamarina201155
kirycha-2000719
Васильевна Владимирович
1сор по информатике 6 класс 3 четверть
Анна1417
info46
qcrv15312
ValerevnaRustam1072
Дмитрий_Владимирович1162
lawyer-2019
александр496
Mukhina1811
Yelizaveta1848